Jump to content

Archived

This topic is now archived and is closed to further replies.

baroth

problem with installation ESET Remote Administrator Server

Recommended Posts

Hello, can someone help me ? i have trouble with instalation

[root@esetserver]# ./server-linux-x86_64.sh --db-hostname="localhost" --db-admin-username=root --db-admin-password=abc --server-root-password=abc --db-user-username=root --db-user-password=abc --cert-hostname="10.0.0.1;Linux;company.LOCAL" --db-driver="MySQL"

ESET Remote Administrator Server Installer (version: 6.5.417.0), Copyright © 1992-2017 ESET, spol. s r.o. - All rights reserved.

Extracting archive, please wait...
Archive extracted to /tmp/tmp.1y5RHkGmrH.
Checking OpenSSL ... done [OpenSSL 1.0.2k-fips 26 Jan 2017]
Reading previous installation settings ... failure
Checking installed version... done
Status of current installation is: NEW
Checking database connection ... failure

Error: Unknown database driver or data source name (DSN)
---

my configs 

CentOS Linux release 7.4.1708

mysql  Ver 14.14 Distrib 5.6.37

comand  isql -v eradb root abc --> works fine - i can connect

[root@servereset]# cat /etc/odbc.ini
[eradb]
Driver = /usr/lib64/libmyodbc5a.so
SERVER = localhost
PORT = 3306
DATABASE = mysql
SOCKET = /var/lib/mysql/mysql.sock
OPTION = 3
USER = root
PASSWORD = abc

----------------

cat /etc/odbcinst.ini

[MySQL]
Description=ODBC for MySQL
Driver=/usr/lib64/libmyodbc5S.so
Setup=/usr/lib64/libodbcmyS.so
Driver64=/usr/lib64/libmyodbc5S.so
Setup64=/usr/lib64/libodbcmyS.so
UsageCount=3
Threading=0
 

in /etc/my.cnf i have 

max_allowed_packet=33M
innodb_log_file_size=100M
innodb_log_files_in_group=2
 

[root@servereset]# find /usr -name "*odbc*.so"
/usr/lib64/libodbc.so
/usr/lib64/libodbcinst.so
/usr/lib64/php/modules/pdo_odbc.so
/usr/lib64/php/modules/odbc.so
/usr/lib64/libmyodbc5S.so
/usr/lib64/libmyodbc5a.so
/usr/lib64/libodbcpsqlS.so
/usr/lib64/libodbcmyS.so
/usr/lib64/libmyodbc5w.so
 

best regards

---------------------

after one hour i found SOLUTIONS

i changed --db-driver="MySQL" to "Driver=MySQL ODBC 5.3 Unicode Driver" and its works

 

 

 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...