Jump to content

Upgrading ESET Endpoint AV 6.2 to 6.4 in ERA 6.3 gives Installation failed with: (0x643)


rpremuz
 Share

Recommended Posts

In our Windows domain network we wanted to upgrade ESET Endpoint Antivirus 6.2.2033.0 to v. 6.4.2014.0 via ERA 6.3.136.0.

 

First we upgraded the ERA Agent on the Windows 7/8.1/10 clients to v. 6.3.136.0, which finished fine.

 

Then we tested the ESET Endpoint Antivirus upgrade via installation tasks that run the appropriate msi installer (eea_nt32_enu.msi or eea_nt64_enu.msi). We noticed that the tasks failed if a user was logged on in Windows. The error was:

 

SoftwareInstallation: Installation failed with: (0x643), Fatal error during installation (0x643), Service 'ESET Service' (ekrn) could not be installed. Verify that you have sufficient privileges to install system services., ...

 

After additional troubleshooting we found out that the error is caused by the Process Explorer running on the client machines. I reported a similar problem with ESET Endpoint AV 5.0 in this forum: https://forum.eset.com/topic/2927-upgrade-of-endpoint-antivirus-50-gives-error-1923/

 

So, so solve this issue we had to kill the Process Explorer before starting upgrade of ESET AV -- this can be done remotely with pskill tool (also of Mark Russinovich):

pskill -t \\hostname procexp.exe

-- rpr.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...