Jump to content

Archived

This topic is now archived and is closed to further replies.

GainfulShrimp

Problem with ESS 8 - cannot save settings or firewall rules

Recommended Posts

Hello,

 

I'm being driven slightly mad by ESS 8, unfortunately.  Everything was working fine (AFAIK), then I foolishly tried to change the firewall to 'learning mode' while I installed controller software for my new wifi AP (Ubiquiti UAP-AC).

 

I got an error 'An error occurred while saving configuration. Please make sure that you have permissions to change settings.' when I clicked OK, but when I close the UI and re-enter it, my choice seemed to be selected still.  Hmm...

 

Now I'm getting constant popups from the firewall but every time I select 'Remember action (create rule)' and click 'Allow', I get a message 'Failed to change settings'.

 

I read a couple of threads about similar issues, but they were apparently resolved in HIPS module v1155 and mine is apparently v1166.

 

I have multiple accounts set up on this system, but only ever log in as one (the other is for a SSH server tool that I use).

 

I *do* log in remotely to this machine (using Remote Desktop) quite often, in case that's important?

 

Here's the summary from About box:

 

Virus signature database: 11355 (20150321)
Rapid Response module: 5714 (20150321)
Update module: 1056 (20150113)
Antivirus and antispyware scanner module: 1451 (20150224)
Advanced heuristics module: 1154 (20150129)
Archive support module: 1222 (20150310)
Cleaner module: 1105 (20150120)
Anti-Stealth support module: 1070 (20150209)
Personal firewall module: 1259 (20141219)
Antispam module: 1029 (20141103)
ESET SysInspector module: 1245 (20141028)
Real-time file system protection module: 1009 (20130301)
Translation support module: 1273 (20141008)
HIPS support module: 1166 (20150310)
Internet protection module: 1173B.2 (20150312)
Web content filter module: 1036 (20140625)
Advanced antispam module: 2147 (20150320)
Database module: 1064 (20150303)
 
Windows 7 Professional (64-bit), Version 6.1.7601 Service Pack 1
Intel® Core i7-3770K CPU @ 3.50GHz (3503MHz), 32729 MB RAM
 
 

Share this post


Link to post
Share on other sites

Are you logged in an administrator account? Standard users don't have permission to create rules or change settings.

Share this post


Link to post
Share on other sites
I'm also getting permissions problems.  Error messages I've had include:

 

"An error occured while reading control file.  The Personal firewall will not work." - comes up each time I start the computer

"An error occurred while saving the configuration.  Please make suer that you have permissions to change settings." - comes up if I change something in advanced settings

 

Running Windows 7, ESET 8.  Account I'm logged into is in the administrators group.

 

I've tried:

- Starting the ESET gui using "Run as administrator"

- Uninstalling and reinstalling ESET Smart Security

- Explicitly giving my user "Full Control" permission to the ESET registry keys

Share this post


Link to post
Share on other sites

First of all, make sure that the file C:\ProgramData\ESET\ESET Smart Security\EpfwUser.dat has the following permissions set:

SYSTEM = Full control

Administrators = Full control

Users = Read & Execute, Read

 

If the permissions are set correctly, I'd suggest contacting Customer care and providing them with EpfwUser.dat as several iterations will be needed to troubleshoot the issue. ESET engineers will need to analyze it.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...