Jump to content

Mirror not functional

Recommended Posts


I’m managing a network on a higher education school (about 200 workstations) and I try unsuccessfully to create on a Windows 2012 Standard Server a functional mirror to update the clients (Windows 7 Pro & Windows 10 Pro). The server provides an typical Active Directory Domain.

The server is running the Eset File Security 6.5 (last update), while the clients are running an Eset Endpoint Antivirus 6.6 version (last update also). I’m not currently using ERA, so I configured both installations manually.

These are the settings used on the server :

-    Advanced Setup -> Update -> Profiles -> Basic : no changes, the default settings are fine, and the regular online updates are working
-    Advanced Setup -> Update -> Profiles -> Mirror :
 •    Create update mirror : checked
 •    Provide updates via http server : unchecked (no http server on site)
 •    Folder to store mirror files : I made a Clear, and set the physical folder of the mirror (e.g. D:\Eset-Mirror). This folder has permissions (I created a special user « NODUSER », wich has « Write » permissions on this folder – the permissions are propagated into the whole content of the folder), and set as a hidden shared folder (e.g. \\server\Mirror$\)
 •    Username : is set on « Domain\NODUSER »
 •    Password : is also set

The settings on the workstations are :

-    Advanced Setup -> Update -> Profiles -> Basic -> Update Server :
 •    Choose automatically : unchecked
 •    Update server : \\server\Mirror$\
-    Advanced Setup -> Update -> Profiles -> Basic -> Update from Mirror :
 •    Username : is set on « Domain\NODUSER »
 •    Password : (same)

On a workstation, I checked the network access on the shared folder (\\server\Mirror$\ from the « NODUSER » account) and it works (the Windows explorer opens, and displays the Eset update files). When I try to update the Eset product on this workstation (e.g. right-click on the icon of the status bar, and select « search for updates »), I still get this message : « an error occured while downloading update files ».

No settings changes I tried this few days managed to solve the problem. What am I doing wrong ?

Thanks for your advices ...

Link to comment
Share on other sites

  • Administrators

EFSW 6.5 doesn't create mirror files for Endpoint 6.6. This will be first supported in EFSW v7. We strongly recommend using HTTP Proxy instead of a mirror to save bandwidth and to ensure that only files that are really needed by clients are downloaded.

If you need to use a mirror, use the command line Mirror tool or create it using Endpoint 6.6.

Link to comment
Share on other sites

Hello Marcos,

Thank you for the prompt answer, really appreciated !

I do not have an HTTP server at my disposal. Do you advise me to deploy Endpoint 6.6 on the server, instead of ESFW 6.5 ? (my local supplier didn't recommend it on a Windows Server, so I'm wondering)


Link to comment
Share on other sites

  • Administrators

For instance, Apache HTTP Proxy is provided with the ERA All-in-one installer or as a stand-alone installer from https://www.eset.com/int/business/remote-management/remote-administrator/download/#standalone:


For instructions how to configure it, read https://help.eset.com/era_install/65/en-US/mirror_tool_windows.html?http_proxy_installation_windows.html.

For instructions on using the mirror tool, please refer to https://help.eset.com/era_install/65/en-US/mirror_tool_windows.html.

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...