Jump to content

ERA proxy on Debian 8.7.1


András Káldor
 Share

Recommended Posts

Hi there!

In a test environment I try to install ERA proxy, the following packages are installed: libmyodbc, unixodbc. On the server MySQL 5.5 is installed.

in 

/etc/odbcinst.ini: (this can be found on server and on the ERA proxy computer as well)

[MySQL]

Description = ODBC for MySQL

Driver = libmyodbc.so

Setup = libodbcmyS.so

Driver64 = libmyodbc.so

Setup64 = libodbcmyS.so

First 2 problem: according to the documentation of 6.4 ERA there (hxxp://download.eset.com/manuals/eset_era_6_userguide_enu.pdf) is a parameter: --db-dbname (page 90). It is incorrect, the correct parameter is --db-name. The last parameter in the example is  --server-root-password, script says no such parameter and I didn't find anything regarding this.

Finally I run a command like this:

./proxy-linux-x86_64.sh --db-hostname=192.168.200.12 --db-name=era_proxy_db --db-admin-username=root --db-admin-password=PWD --db-user-username=root --db-user-password=PWD --db-port=1433 --db-type="MySQL Server" --db-driver=SQL --skip-license --hostname=192.168.200.12 --port=2222 --cert-path=/home/nd/Downloads/debian-gui-proxy.pfx --cert-auth-path=/home/nd/Downloads/debian-gui-CA.der

 

the error I got:

Checking database connection ... failure

Error: Unknown database driver or data source name (DSN)

ERA6 is installed on 192.168.200.12 with MySQL, and it works great.

How can I connect ERA proxy to the server DB?

Regards

András

Link to comment
Share on other sites

  • ESET Staff

My recommendation is to use more current online documentation. Regarding this specific error, problem is that you do not have ODBC driver named "SQL" specified in odbcinst.ini -> instead driver named "MySQL" (part named [MySQL]) seems to be available, therefore I would recommend to use  --db-driver=MySQL installation parameter.

 

Link to comment
Share on other sites

Dear Marint!

Thank you for your answer. That was one of the mistake I made, the other one was the port numer, the correct one: --db-port=3306.

I will you the online doc. The online one still contains the param: --server-root-password, what I was unable to use as script said no such param.

Regards

András

Link to comment
Share on other sites

  • ESET Staff
1 hour ago, András Káldor said:

I will you the online doc. The online one still contains the param: --server-root-password, what I was unable to use as script said no such param.

You are right. Mentioned parameter is not used by PROXY installer and should be excluded from example.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...