Jump to content

Archived

This topic is now archived and is closed to further replies.

LocknetSSmith

Transfering Database to MySQL Database

Recommended Posts

I wanted to post this in hopes of helping others that may come across this problem, so you won't have to go through the frustration I had to go through!

 

I weas rebuildling my MSP ERAS/ERAC - we won't go into why.  Due to the size of our database in its current state, and the size that it will be when fully ramped up, we were told to use MySQL, with an opportunity to potentially transfer to MS SQL in November (I suspect that if I was using MS SQL right now I wouldn't be posted this as we have MS SQL admins here). 

 

When a co-worker initially built the MsSQL database 7 months ago, he sat on the phone with an ESET Engineer for half a day before they were able to get it to work.  That is no longer an option for us, so using the ESET KB, I have been attempting to do this myself.

 

As those of you that use the MSP model for ESET Remote Administration know, when you install EMU, it installs ESET RA Server/Console for you, but with default settings, which includes setting up MS Access as the database.  This won't work for us, so the option was to install MySQL, and setup an ESET database within it.

 

I downloaded and installing MySQL

 

But in the ERA Maintenance Tool, despite my best efforts, I could not get a successful connection.

 

Connection Test Failed:

Operation: [DriverConnect] Native: [0x7D5] State: [s1000]

[MySQL][ODBC 5.2(a) Drive]Unknown MySQL server host

'localhost' (2)

 

Here is my connection string:

Driver={MySQL ODBC 5.2 ANSI Driver};Server=locahhost;Database=ESET_RA_DB

 

I have also tried this:

Driver={MySQL ODBC 5.2 ANSI Driver};Server=hostname;Database=ESET_RA_DB

 

Both Failed.

 

In order to finally get this to work, you have to create a new schema in your MySQL database.  The name seems to be important, you have to use eset_ra_db  - I tried several other names, include the default MySQL, but this will not work.  You also have to create a non-root user account that has full admin rights to the database.  I used eraxxxx (x's are numbers I withheld).  Obviously use a complex password that never expires.

 

Once this is done, configure your ODBC connector.  Note, you HAVE to use the 32 bit ODBC connector reguardless of whether your Server is 64 bit.  I'm personally guessing this is because the ESET RA Server software architecture is 32 bit.

 

Finally, in the ERA Maintenance Tool, for your Source database (Microsoft Access if you just installed EMU), you have to test your connection and make sure you get a success message.  For your destination database, here is the connection string that I used that finally got me up and running:

 

Driver={MySQL ODBC 5.2 ANSI Driver};Server=127.0.0.1;Database=ESET_RA_DB

 

Cheers,

S~

 

 

 

 

Share this post


Link to post
Share on other sites

Just an update to this - apparently using a Connection string (as above) is not the most efficient method for the ERAS to write to a MySQL database (I want to specifically thank ESET's awesome business support team lead for this information) is by using a DSN Connection string.  This works with the driver much more efficiently, whereas the Connection String I listed above is more like "up one, over two, tilt to the left, etc. before writing the data to the MySQL tables. 

 

So the word for our environment, is to use DSN=%insert database name here%

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...