Jump to content

Deleting mobile device entry from ERA database


chetankb1
 Share

Recommended Posts

Hi All,

 

Please let me know, how I am suppose to remove Mobile Device entry from ERA database manually & safely. I have removed ESET Endpoint Security from mobile and removed the entry from ERA, but the device is reappearing in the ERA console again and again.

 

Note: I am using latest version of ERA 6.4.

 

Please HELP.

Link to comment
Share on other sites

  • ESET Staff

What is needed to do, is to perform the "stop managing / uninstall ERA agent" with the target set to the entry of the no-longer existent Android machine.

After the task has been executed, you would be able to remove the device, and it should not reappear. 

Edited by MichalJ
Link to comment
Share on other sites

I have tried with the same process.

 

"stop managing / uninstall ERA agent" task is keeps running(task won't complete). If I delete the computer in this situation, device is reappearing.

Link to comment
Share on other sites

  • ESET Staff

What is the version of the Mobile Device Connector? Was it upgraded to version 6.4 ? Please provide details about the MDMCore version, as this issue was present on the version 6.3 and older, however should not happen on the latest version. 

Link to comment
Share on other sites

HI,

 

ESET Remote Administrator Mobile Device Connector 6.4.252.0
 
ESET Remote Administrator Server 6.4.295.0 & it is not upgraded from 6.3. This is a fresh installation.
Link to comment
Share on other sites

  • 2 weeks later...
  • ESET Staff

Hello,

this should not happen in your version, so there is something wrong going on. I suggest you contact the support and provide details to them.

 

As a quick and dirty solution, it is possible to remove the device manually - go to MDC's database and remove the device's row from the Device table - you can identify the device by the DeviceID column (contains the IMEI or MAC for Android devices, UDID for iOS devices). After deleting the row, restart the MDC service and then remove the device from ERA webconsole. It should not reappear anymore.

 

However, we would really appreciate if you first contacted support so that we can fix whatever has caused the issue in the first place.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...