Jump to content

Firewall blocks RDP from remote IP's


Recommended Posts

I'd like to access my home pc with my laptop across the internet from anywhere. My problem is that my firewall is blocking this connection. I tried creating a rule, but i can't know the IP adress in advance. I want to allow all incoming connection from port 3389, but I have no idea how to do this.

 

Any suggestions? Thanks in advance!

Link to comment
Share on other sites

The following will initiate a RDP session from your home PC. If in the below step 3. you create a permanent rule, you are opening up your home PC to a remote connection from any PC. Don't know if this works on Win 10.

 

As far as what you want to do, i.e. external laptop connection, as far as I am aware of, it can't be done in the Eset firewall. It only supports RDP in the Trusted zone implying your home LAN. Eset doesn't support in the firewall, source by device MAC. And that is what you would need to positively id your laptop in an allow MSTSC.EXE application inbound traffic firewall rule. 

 

1. Make sure RDP is enabled in Windows on your home PC.

 

2. Click on “Setup” of ESET smart security and then “Enter Advanced Setup” -> Expand “Network”  And then Click on “Personal Firewall” and then change the Filtering mode to “Interactive mode” and then click “OK."

 

3. Now try to initiate the Remote desktop from Internet to your computer, and then you will get a pop-up in ESET asking if you want to allow or Deny MSTSC.EXE application traffic. Click on Allow.

 

4. If firewall mode was previously set "Automatic," reset the firewall to same.

Edited by itman
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...