Jump to content

Archived

This topic is now archived and is closed to further replies.

SCR

SSL/TLS scanning delay

Recommended Posts

Of late I'm getting a delay while Eset   v10.0.171.0 is "establishing a secure connection" in Chrome. As time goes by the time it takes is increasing to 40 or more seconds. Disabling SSL/TLS scanning removes the problem.

 

Any suggestions would be appreciated.

 

Win 7 Pro - sp1 x64.

Share this post


Link to post
Share on other sites

Hello SCR,

 

does it happen with all secured sites (httpS), or just with some of them?

 

Other browsers suffer from this issue too, or not?

 

Is they delay the same after system restart or it increases over the time?

 

Regards, P.R.

Share this post


Link to post
Share on other sites

Hello SCR,

 

can you please provide us with a few logs, so we can check it with developers?

 

1. Enable Protocol filtering advanced logging (open ESET main GUI, press F5 to open the advanced settings, go to Tools->Diagnostics-> Enable Protocol filtering advanced logging)

reproduce the issue and stop the logging. Once complete press "Open button" next to the Open diagnostics folder in the Diagnostics pane and send me the EsetProxyInner.pcapng and EsetProxyOuter.pcapng files.

Also please note 2. exact time with timezone info, when the issue occurred, in case you get any 3. error message please copy it, 4. exact system version and 5. copy the about information - in the main GUI go to Help and support -> About ESET Internet Security -> Installed components -> copy (it will copy all the info to your clipboard)

 

Once you have the logs and info collected, please send me and TomasP private message, we will check it.

 

Thank you, P.R.

Share this post


Link to post
Share on other sites

Hello SCR,

 

does it happen with all secured sites (httpS), or just with some of them?

 

>>Yes, all of them

 

Other browsers suffer from this issue too, or not?

 

>> Yes,  PaleMoon has the same problem

 

Is they delay the same after system restart or it increases over the time?

 

>>The first https site may take about 5 to 10 seconds to establish the secure connection subsequent https connections to different sites increase the time needed to establish the connection. System restart starts the process of establishing the connection over time wise.

 

Regards, P.R.

See in line reply

 

Once either browser establishes the connection and I close the tab and go back to the site all works as expected. If I close the browser and open a new instance the problem starts over but the time needed to establish the connection takes longer.

 

I have reinstalled both  Eset Internet Security and Chrome with no change. The issue occurs with a clean browser (No add on or extensions).

 

Thanks for your reply.

Share this post


Link to post
Share on other sites

Hello SCR,

 

thank you for your reply.

Would it be possible for you to collect the logs mentioned in my second reply so we can have a look at it with the devs?

 

Thank you, P.R.

Share this post


Link to post
Share on other sites

Yes I will do as requested. I am working on it now but I am also expecting a furniture delivery at any moment so it will be a little delayed.

Share this post


Link to post
Share on other sites

not an issue, take your time, I hope the furniture will arrive as expected and will make you home a nicer place. :-)

 

Thank you, P.R.

Share this post


Link to post
Share on other sites

SCR: Is there a chance you need to use an HTTP proxy to connect to the internet?

Share this post


Link to post
Share on other sites

SCR: Is there a chance you need to use an HTTP proxy to connect to the internet?

I am not sure. Could you give me some more information or direct me to where I can find more.

 

Presently it seems that the delay only occurs when I go to a site the first time. On subsequent visits, even after a reboot, I do not experience the delay. It's almost like Eset is learning the site and connects straight away after it does. Then again I'm not even sure this is something Eset does.

 

Thank you for your reply.

Share this post


Link to post
Share on other sites

could it be that it is a ocsp related issue?

 

chrome is using a lokal file to check it and i think eset is talking to the ocsp servers to validate the certificate

 

please check if it is also present if your using firefox (without esets tls scan)

if so please temporary disable ocsp under about:preferences#advanced /certificate

Share this post


Link to post
Share on other sites

You might check the settings under Control Panel->Internet Options->Connections->LAN Settings and un-check "Automatically detect settings" if its checked (and you don't actually need Windows to try to figure out your proxy settings automatically). I've seen that cause delays like what you mention.

--

bc

Share this post


Link to post
Share on other sites

could it be that it is a ocsp related issue?

 

chrome is using a lokal file to check it and i think eset is talking to the ocsp servers to validate the certificate

 

please check if it is also present if your using firefox (without esets tls scan)

if so please temporary disable ocsp under about:preferences#advanced /certificate

Thank you for your reply. I do not have FireFox installed on this system.

 

You might check the settings under Control Panel->Internet Options->Connections->LAN Settings and un-check "Automatically detect settings" if its checked (and you don't actually need Windows to try to figure out your proxy settings automatically). I've seen that cause delays like what you mention.

--

bc

Thanks for your suggestion, Since making the suggested change I have not had the delay. I will test further.

Share this post


Link to post
Share on other sites

It's my best guess that an Eset update corrected this issue.

 

Many thanks to all who participated in trying to help me resolve the problem. 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...