Jump to content

Issue upgrading Win 10 1551 to 1607 with ESET 6.4.2014.0 installed


tcm123
 Share

Recommended Posts

As the title suggests when performing an upgrade of Windows 10 1511 (Education x64) to 1607 the installation fails.

 

I have managed to dig through the logs and found the following in the "c:\$WINDOWS.~BT\Sources\Panther\setuperr.log"

 

DRVMIG: Failed to inject driver package in the new OS (payload hardlinked): C:\Windows\System32\DriverStore\FileRepository\ehdrv.inf_amd64_afab37c21652b95d\ehdrv.inf. Error: 0x80070002[gle=0x0000007a]

 

I believe that ehdrv.inf is an ESET driver. I am wondering if the ESET engineers can take a look at this, as either disabling or uninstalling ESET before doing an upgrade is going to make the task a very tricky process.

Link to comment
Share on other sites

I can confirm the problem. I had it on 2 different devices running Eset Endpoint AV 6.2 and 6.4.

 

I could only upgrade to 1607 after uninstalling Eset before upgrading Windows 10.

I also tried it with the newest ISO, but this showed an error regarding the driver installation (probably the same you were seeing in your log).

 

I think I will open a case as this can't be a normal operation for an Enterprise product.

Imagine uninstalling Eset on 100 PCs, leaving them half-protected by Windows Defender until WSUS got everyone upgraded, and then having to reinstall Eset on all of them.

Sound like a week of unnessesary "fun" for the admin (me) every 6 months, when MS puts out a feature upgrade!

Link to comment
Share on other sites

is this using ESET Antivirus or ESET Smart Security? I've upgraded about a dozen Pro and Enterprise x64 machines from 1511 to 1607 without issue and they all had Antivirus (6.4.2014.0). So I'm wondering if your issue relates to Smart Security, and if not, the perhaps there's another reason (despite the message). Or maybe the specific config you have in the ESET client?

 

 

Jim

Edited by jimwillsher
Link to comment
Share on other sites

  • 3 weeks later...

i can confirm the same with ESET AV, upgrading from 1511 enterprise to 1607, local upgrade using the 1607 enterprise iso, 

after i uninstalled ESET, the install ran fine, this is on a surface book, freshly installed with windows 1511 this week as well.

 

i have not yet rolled out the 1607 update via WSUS, but i hope its not going to be an issue? ill have to see if this is happening on a few PC before the roll out?

Link to comment
Share on other sites

  • 4 weeks later...

i can confirm the same with ESET AV, upgrading from 1511 enterprise to 1607, local upgrade using the 1607 enterprise iso, 

after i uninstalled ESET, the install ran fine, this is on a surface book, freshly installed with windows 1511 this week as well.

 

i have not yet rolled out the 1607 update via WSUS, but i hope its not going to be an issue? ill have to see if this is happening on a few PC before the roll out?

 

I'm just wondering, are you using 32 or 64 bit Windows? 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...