Jump to content

Howto change Webif port from 8443 to 443 in virtual Appliance (CentOS)?


j.schulz
 Share

Recommended Posts

Hi,

 

we are using the virtual appliance and it's configured to use 8443 for the webif, i would like to have it on 443 purely.

When i try to change the port in server.xml from 8080 to 443 and restart tomcat the webif isn't reachable anymore.

 

I haven't touched the redirection from 8080 repective 443 to 8443, i am confused is the port 443 reserved for something else?

 

Please tell me how i can change to 443?

 

 

Regards Jens

Link to comment
Share on other sites

  • ESET Staff

Have you checked whether tomcat is listening on port 443 after changes (using netstat -taun)? My guess is that is is not listening, because configuring tomcat to listening on privileged port (all ports under 1024) requires higher permissions that it has as it is not running as root. This is also reason we used 8443 instead of 443.

 

In this case i would suggest to revert tomcat configuration changes and instead modify iptables firewall rules so that port 443 is forwarded to 8443. For example adding something like this:

iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 443 -j REDIRECT --to-ports 8443

to /root/firewall.sh file should enable port redirection. It may be also required to open port 443 from outer network by modification of /root/firewall-ports.sh.

 

PS: this steps were targeted for ERA 6.3 or older appliance based on CentOS6. Applying it on CentOS7 based appliance released with ERA 6.4 may be different.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...