Jump to content

unable to install new agent


TomTomTom
 Share

Go to solution Solved by TomTomTom,

Recommended Posts

Hi

 

on several machines and servers the update to the newest version worked fine, but now I have a problem with the installation of the new agent.

 

Currently running on my SBS 2011 is the Agent 6.2.190.0. I want to update to Version 6.3.136.0

 

If I start the installation, after a short time a window appears: Service 'ESET Remote Administrator Agent' (EraAgentSvc) could not be stopped. Verify that you have sufficient privileges to stop system services.

 

YES, I logged in as administrator.

 

In ERAS console an actual time for last communication is ok, but on the server the update was running successful, in the console an outdated version is displayed.

 

Something seems to be unstable now - what can I do now?

 

Thanks

Link to comment
Share on other sites

  • ESET Staff

This error means that AGENT's service cannot be stopped in time. This may be caused by multiple issues:

  • long running task is being executed
  • huge amount of logs are being fetched from security product.
  • service is protected by security product which is blocking setup to stop AGENT's service

Is there any security product installed - if yes, provide please version information (application version + modules version)? Have you tried to restart this system and upgrade after?

Edited by MartinK
Link to comment
Share on other sites

There is ESET Mail Security 6.3.10005.2 installed. The following modules are installed on the server:

 

Signaturdatenbank: 13736 (20160701)
Soforteinsatz-Modul: 8287 (20160701)
Updates: 1064 (20160324)
Viren- und Spyware-Schutz: 1491 (20160630)
Advanced Heuristik: 1171 (20160614)
Archivunterstützung: 1251 (20160627)
Säuberungstechnologie: 1123 (20160606)
Anti-Stealth-Unterstützung: 1098 (20160525)
Spam-Schutz: 1029 (20141103)
ESET SysInspector: 1259 (20160406)
E-Mail-Server-Schutz: 1009 (20120312)
Echtzeit-Dateischutz: 1010 (20150806)
Lokalisierungsunterstützung: 1500 (20160623)
HIPS-Unterstützung: 1235 (20160622)
Internet-Schutz: 1255 (20160601)
Erweiterter Spam-Schutz: 3938 (20160701)
Datenbank: 1082 (20160601)
Konfigurationsmodul (36): 1254 (20160203)
LiveGrid-Kommunikationsmodul: 1021 (20160310)
Rootkit-Erkennungs- und Bereinigungsmodul: 1003 (20160508)
Netzwerk-Schutzmodul: 1191 (20160630)

 

At the moment it is not possible for me to reboot the server in my productive environment.
 

Link to comment
Share on other sites

  • ESET Staff

Modules should be compatible with AGENT, problem will be somewhere else.

Could you please send me (Private Message) trace log of problematic AGENT installation? It should be located in path:

C:\ProgramData\ESET\RemoteAdministrator\Agent\EraAgentApplicationData\Logs\trace.log

or it's equivalent on this operating system.

 

Have you tried upgrade only once or multiple times, even some time later after first attempt? In case stop won't be possible even after longer time, one of possible workaround is to stop service manually (= kill ERAAgent.exe process) and re-try upgrade procedure.

One last question: is there any visible activity (CPU usage) of ERAAgent.exe, ekrn or other ESET applications? This may be interesting especially in case it will be higher.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...