Jump to content

upgrading ESET Remote Administrator v. 6.2 to v. 6.3


rpremuz
 Share

Recommended Posts

I've upgraded ESET Remote Administrator v. 6.2.11.1 to v. 6.3.136.0 and I'd like to report my experience with the procedure.

 

ESET Remote Administrator v. 6.2.11.1 was installed on s MS Windows Server 2012 using the ESET Remote Administrator 6 All-in-one Installers for MS Windows 64-bit. After the configuration ERA was running fine and we were able to remotely install and administer our ESET clients in the ERA Web Console.

 

For the upgrade to ERA 6.3.136.0 I followed instructions given on hxxp://help.eset.com/era_install/63/en-US/?components_upgrade.htm which recommends using the Remote Administrator Component Upgrade task available in the Web Console:

  • ADMIN → Client Tasks → All Tasks → ESET Remote Administrator → Remote Administrator Components Upgrade → New
    • NAME: Remote Administrator Components Upgrade
    • TASK: Remote Administrator Components Upgrade
    • TARGET: myserver
    • TRIGGER: As soon as possible
    • SETTINGS
    • enable "I agree with application End User License Agreement"
    • REMOTE ADMINISTRATION SERVER: ESET Remote Administration Server 6.3.136.0 for Windows
    • disable "Automatically reboot when needed"
    • Finish

The console reported that the task finished successfully. But some parts of the Web Console showed an error:

  • ADMIN → Client Tasks showed "FAILED TO LOAD DATA: INTERNAL REPORT ERROR"
  • ADMIN → License Management showed "FAILED TO LOAD DATA: REPORT TEMPLATE IS INCORRECT"

The log file in C:\Windows\temp\ra-upgrade-agent.log did not mention any obvious errors.

 

I tried to fix the issue by restarting the server at a later time but to no avail. ERA components had the following versions:

  • ESET Remote Administrator Agent 6.3.136.0 - upgraded
  • ESET Remote Administrator Server 6.2.171.0 - old version
  • ESET Rogue Detection Sensor 1.0.959.0 - old version

So, I conclude that the Remote Administrator Component Upgrade task upgraded only the ERA Agent while other two components were not upgraded.

 

The troubleshooting section of the manual recommends performing a manual component-based upgrade of ERA Server and Web Console as explained on hxxp://support.eset.com/kb3668/#component. I followed those instructions and upgraded all the ERA components successfully but I must admit that the procedure was quite difficult, partially due to some mistakes in that KB article which you can find in the attachment.

 

Here is the procedure of the manual upgrade:

  1. From https://www.eset.com/int/download-business/ download ESET Remote Administrator 6 All-in-one Installers for MS Windows 64-bit and unpack it in "C:\Temp\ESET Remote Admin 6.3.136.0".
  2. Stop Apache Tomcat 7.0 service (after that you can't use the ERA Web Console).
  3. Back up "C:\Program Files\Apache Software Foundation\Tomcat 7.0\webapps\era".
  4. Remove "C:\Program Files\Apache Software Foundation\Tomcat 7.0\webapps\era\webconsole".
  5. With 7-Zip open "C:\Temp\ESET Remote Admin 6.3.136.0\installers\era.war" and unpack it to "C:\Program Files\Apache Software Foundation\Tomcat 7.0\webapps\era" overriding the existing files.
  6. Restore the EraWebServerConfig.properties file from the backup, that is copy old "...\era\WEB-INF\classes\sk\eset\era\g2webconsole\server\modules\config\EraWebServerConfig.properties" to "C:\Program Files\Apache Software Foundation\Tomcat 7.0\webapps\era".
  7. Upgrade ERA Remote Administrator Server to v. 6.3.136.0 by running "C:\Temp\ESET Remote Admin 6.3.136.0\installers\Server_x64.msi". The most difficult part in this step is "Database server connection" where you have to specify the database settings you used with ERA 6.2. In my case the upgrade finished successfully. I started the Apache Tomcat 7.0 service and logged in to ERA Web Console which did not show the "FAILED TO LOAD DATA" errors any more.
  8. Upgrade ESET Rogue Detection Sensor to v. 1.0.1049.0 by running "C:\Temp\ESET Remote Admin 6.3.136.0\installers\RDSensor_x64.msi". In my case the upgrade was also successful.

Finally, I also upgraded Apache Tomcat v. 7.0.64 to v. 7.0.69 as instructed on hxxp://help.eset.com/era_install/63/en-US/index.html?upgrading_apache_tomcat_windows.htm.

I also tried to upgrade the Apache Tomcat to ver. 8.0.35 but the service would stop immediately after start. Its logs showed that the following line from server.xml is not accepted by the new version:

  <Listener className="org.apache.catalina.core.JasperListener"/>

-- rpr.

errata.txt

Edited by rpremuz
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...