Jump to content

How to update ERA Host server address on remote clients?


ShaneDT
 Share

Recommended Posts

The scenario. Multiple remote notebooks that rarely visit the office. Eset agent configured to report back to the ERA server via the office Internet IP address.

 

Customer changes ISP without telling IT Support... Eset agent on remote notebooks no longer reporting back to ERA server...

 

Can I simply create a new EraAgentInstaller with the new ISP Internet IP as the host server address, email this out and have the users run this on their notebooks?

If yes can I just modify the following line in the existing EraAgentInstaller.bat file?

set server_hostname=

 

Thanks :)

Link to comment
Share on other sites

  • Administrators

If the ERA server was not reinstalled, you can change the server name in the Agent Live installer batch file and re-deploy it on clients. If ERAS has been reinstalled, create a new Agent Live installer from the console so that it contains both the correct server name as well as certificates that are currently being used.

Link to comment
Share on other sites

Thanks Marcos, there has been no change on the ERA server itself, just wasn't sure if you could re run the EraAgentInstaller.bat on a computer that already has the agent installed.

 

Will run it and report back how I go :)

Edited by ShaneDT
Link to comment
Share on other sites

Didn't work. Ran the modified EraAgentInstaller.bat. Status Log still reporting replication failure to the old IP address.

Restarted the computer to restart all services. Status Log still reporting replication failure to the old IP address.

Now testing an uninstall of the agent and then reinstall using the modified bat file. Hopefully this should work.

 

Where does the agent store this server_hostname value? I couldn't find it in the registry so assume it must be in a configuration file?

Link to comment
Share on other sites

Uninstall / reinstall worked. This created a new object in the Lost & Found static group. Running Static Group Sync moved it back to the correct static group re Group Policy. The old object for this computer hasn't been removed though (or merged), so I've had to manually deleted the old object.

Link to comment
Share on other sites

  • ESET Staff

The most probable reason why it didnt work was that installed version of ERA agent was older, than the currently available one. So running the live installer will perform "upgrade" (install new version over old one), but keep the settings. If you run it again, it will perform "repair", meaning change the config with the new parameters. So in such cases, you shoul reinstall it twice, to achieve the desired state.

Link to comment
Share on other sites

Hi Michael, I don't think that was the case. The .bat file appears to call a specific version of the agent, in this case 6.3.136.0. So it should have been the same version as it was the same bat file, only the server_hostname parameter was changed.

 

And to verify I just checked the details of the duplicate entries in ERA Server, they are both reporting installed agent as 6.3.136.0 (I haven't deleted the duplicate yet, was waiting to see if it might clean itself up). So the uninstalled and reinstalled agent version is the same.

Link to comment
Share on other sites

  • ESET Staff

Hi Michael, I don't think that was the case. The .bat file appears to call a specific version of the agent, in this case 6.3.136.0. So it should have been the same version as it was the same bat file, only the server_hostname parameter was changed.

 

And to verify I just checked the details of the duplicate entries in ERA Server, they are both reporting installed agent as 6.3.136.0 (I haven't deleted the duplicate yet, was waiting to see if it might clean itself up). So the uninstalled and reinstalled agent version is the same.

 

Any chance you have trace.log before you uninstalled AGENT?

 

After repair with new hostname, AGENT should be trying to connect to this hostname, and if it fails, it will attempt to connect to last hostname that worked in history (this is fallback in case configuration is accidental broken). Therefore you have seen failed connection attempts to old address in status log. Unfortunately previous error (in this case most relevant) was not visible.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...