Jump to content

SQL Server Agent (ERASQL) Not starting


Go to solution Solved by DDJ85,

Recommended Posts

Hi guys,

 

We have issues with our ERA.

The service SQL Server Agent (ERASQL) is starting for 1second and then stops again.

And after that it won't start at all.
 

 

What we have tried:

- Repair SQL server

- Repair the ESET install

- Starting and stopping all SQL services

- Running the service under different users ( local admin and a created user with admin rights etc.)

 

 

Does anyone know a fix for this ?

Link to post
Share on other sites
  • Solution

 

Hi @DDJ85,

 

Well if an Uninstall with reboot-install again SQL doesn't work.

I will start collecting some logs with using:

  • ESET Log Collector
  • ESET SysInspector
  • Process Monitor (filtering and catching all related to SQL)

 

Thanks, pretty new to this so.. will look into it

 

jimwillsher, on 19 May 2016 - 07:31 AM, said:snapback.png

What does Windows Event Viewer show? Eventlog (and SQL log) are normally very verbose, and there's always a clue in there.

 

Found the following, but doesn't make sense to me, as it worked before, and there where no updates installed whatsoever;

 

System

  - Provider

   [ Name]  SQLAgent$ERASQL

 

  - EventID 103

   [ Qualifiers]  16384

 

   Level 2

 

   Task 2

 

   Keywords 0x80000000000000

 

  - TimeCreated

   [ SystemTime]  2016-05-18T13:46:25.000000000Z

 

   EventRecordID 20886

 

   Channel Application

 

   Security

 

- EventData

   This installation of SQL Server Agent is disabled. The edition of SQL Server that installed this service does not support SQL Server Agent.

 

 

*******************************************

Edit: We found the issue. According to a ESET tech that service isn't used. Our problem was in the task itself.

Edited by DDJ85
Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...