Jump to content

Agent Deployment is very slow

Go to solution Solved by MartinK,

Recommended Posts

Our company started using ERA v6 two months ago. Although it takes some getting used to, we didn't have much problems. Currently we're in the process of upgrading al PCs to Windows 10 (clean installs).


The last thing on the TODO check-list is to deploy the agent through the server task and install NOD32 remotely. I'm noticing that deployment can take up anywhere from 20-40 minutes which seems a bit too long as this (as far as I know) wasn't the case when I first started using ERA. On the last two computers the Logs said that deployment was successful, but the agent is nowhere to be found on the target PC, so it took 3 tries before it finally appeared in "programs and functions" and started to communicate with ERA.


I have no idea where to start looking for the cause of the problem. Our local network and Win2008R2 (where ERA is installed) doesn't appear to be under any load. The remote installation of NOD32 after that however completes in about 5min or less.


Also on a maybe related note. Initial definition updates from the proxy which can be around ~50mb in size also download very slowly (kilobytes/s), which doesn't represent our network capabilities at all.


Any help would be greatly appreciated.



Link to comment
Share on other sites

  • ESET Staff
  • Solution

Did it took 20-40 minutes to deploy on one or multiple computers? Only difference with previous versions is that we are not deploying parallel as it cause more problems, but this seems to be more issue with slow downloading of data, most probably caused by slow HTTP Proxy. In case you are using Apache HTTP proxy distributed ERA, could you specify version you are using? If I recall correctly, previous versions had bugs that may have caused similar behavior - especially in case it was running longer - have you tried to restart it and check updates download speed? There is also chance that ESET download servers were overloaded at that time, as both updates and installer are downloaded from the same infrastructure.


Regarding missing AGENT after successful deployment: could you please verify that it was actually being installed on correct machine? We have seen cases where customers were using dynamic IP addresses and remote deployment of the same computer was installing AGENT on different PCs. Deploying the same "computer" to multiple PCs may cause serious problems because multiple AGENT will be reporting as one computer in Webconsole.

Link to comment
Share on other sites

Apache HTTP Proxy, v2.4.18

ESET Remote Administrator (Server), Version

ESET Remote Administrator (Web Console), Version


I'm currently only running the Agent Deployment Task for one target at a time, but something definitely went wrong in the last few weeks as the task targeting about 70 computers, (some were not powered on) finished in around 4 hours.


I'm using Active Directory to synchronise the list of present computers, so I only see domain computer names and not IP addresses before deploying the agent. But if I understood correctly, running the deployment task on a machine which already has the Agent installed could cause problems? I was under the impression that ERA would simply reinstall the Agent or just ignore it, since I might have rerun the Agent Deployment task on some targets when I was still getting familiar with ERA v6 and didn't notice any anomalies.


I managed to squeeze in a Server reboot and the last agent deployment task successfully finished in less than 10 minutes so this might have actually fixed it. Hopefully the slowdown won't happen too often, but I guess it isn't that big of a deal if a reboot can fix it.


The first part of the definitions update after a clean install still progresses very slowly, until it reaches the ~15mb mark, then the download speed spikes from kilobytes/s to megabytes/s (clients currently only download from our http proxy). It's odd, but since it happens automatically it doesn't slow down my work.


Thank you for your time!

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...