Jump to content

Archived

This topic is now archived and is closed to further replies.

Guest Joe Murphy

Upgrading ERAC/ERAS and ESET clients ??

Recommended Posts

Guest Joe Murphy

I submitted a ticket to ESET support and they kindly sent me some links to complete upgrade but I think my situation is unique. Could you help us determine the best way to upgrade ERAC/ERAS as well as the ESET clients currently in our environment?
 

  • Do we have to upgrade ERAS/ERAC first?
  • Is there a major change to the database?
  • Are we going to lose all of our existing policies?
  • Will the clients upgrade from 4.0 to 5.0 directly or are there intermediary upgrades that need to take place?
  • If there are intermediary upgrades how do I download an older version (say 4.2) of ESSBE so I can complete this step?

 

I already have the links to articles on ESET website so I dont' think I'll need those again. I'm looking for someone who has stepped through this process of going from 4.0 to 5.0 directly. That poses the greatest challenge as I don't want to go remote onto all of these computers and conduct the upgrade manually if at all possible.

 

Here are all of the versions in my environment:
4.0.474 (ESSBE)
4.2.40 (NOD32)
4.2.58 (NOD32)
4.2.64 (ESSBE)
4.2.71 (ESSBE)
4.2.71 (NOD32)
5.0.2122 (ESET Endpoint Security)

Current version of ESET Server:

ERAC: 4.0.138.0
ERAS: 4.0.138.0

Thank you.

Regards,
Joe Murphy

Share this post


Link to post
Share on other sites

 

Do we have to upgrade ERAS/ERAC first?

Yes. ERAS version 4 cannot manage clients version 5.

 

 

Is there a major change to the database?

Don't know, upgrade went smoothly, no needed to study database changes.

 

 

Are we going to lose all of our existing policies?

Policies for clients version 4 will stay unchanged, you should make new policies for clients version 5 after ERAS upgrade. There will be separate policies tree for v5 in configurator.

 

 

Will the clients upgrade from 4.0 to 5.0 directly or are there intermediary upgrades that need to take place?

From 4.0 to 5.0 you can upgrade directly

Share this post


Link to post
Share on other sites
Guest Joe Murphy

Thanks karlisi.

 

We are not only upgrading from 4.0 to 5.0, we are also migrating to a new server.

 

Have you had an experience conducting a migration?

 

Thanks,

Joe

Share this post


Link to post
Share on other sites

No, sorry. We plan to migrate in next two weeks, so your experience can be useful.

Share this post


Link to post
Share on other sites

Hi

 

Joe - don't worry - just in installation wizzard select Advaced installation, in one of steps You will se info do you want to keep current settings -> just select it :) and everything will work fine, remember as karlisi wrote that You will have to create new policies for v5.

The current cfg from v4 can be easy migrated to v5 - when You export cfg from v4 open it in some editor (ex. Notepad++) and edit it. On the top of this file You will see string:

 

<?xml version="1.0" encoding="utf-8"?>
<ESET>
 <SECTION ID="1000105"> ----> this is for v5 (Endpoints) in Your exported cfg file You will have other number - just change last number to 5 and endpoint will accept settings from v4 - ofcourse only these which are avilable in v4 and v5
 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...