Jump to content

Error "big blocks of data in the database"


macros
 Share

Recommended Posts

Hello,

 

we install era server on centos 7.

when we try to install Server-Linux-x86_64.sh then this message came up.

 

ESET Remote Administrator Server Installer (version: 6.3.148.0), Copyright © 1992-2016 ESET, spol. s r.o. - All rights reserved.

Extracting archive, please wait...
Archive extracted to /tmp/tmp.RcJuQyFhOS.
Checking OpenSSL ... done [OpenSSL 1.0.1e-fips 11 Feb 2013]
Reading previous installation settings ... failure
Checking installed version... done
Status of current installation is: NEW
Checking database connection ... failure

Error: It is not possible to store big blocks of data in the database. Please reconfigure the database server first.

 

we already change my.cnf. looks like this.

restart mysql service, even restart the server.

but still get the same error.

 

# For advice on how to change settings please see
# hxxp://dev.mysql.com/doc/refman/5.6/en/server-configuration-defaults.html

[mysqld]
max_allowed_packet=33M
# Remove leading # and set to the amount of RAM for the most important data
# cache in MySQL. Start at 70% of total RAM for dedicated server, else 10%.
# innodb_buffer_pool_size = 128M
#
# Remove leading # to turn on a very important data integrity option: logging
# changes to the binary log between backups.
# log_bin
#
# Remove leading # to set options mainly useful for reporting servers.
# The server defaults are faster for transactions and fast SELECTs.
# Adjust sizes as needed, experiment to find the optimal values.
# join_buffer_size = 128M
# sort_buffer_size = 2M
# read_rnd_buffer_size = 2M
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock

# Disabling symbolic-links is recommended to prevent assorted security risks
symbolic-links=0

 

 

is there anything wrong, and how to solve this.

 

thank you.

Link to comment
Share on other sites

  • ESET Staff

Seems you are missing configuration of parameters:

innodb_log_files_in_group=2
innodb_log_file_size=128M

Please before applying, confirm it in /var/log/eset/RemoteAdministrator/EraServerInstaller.log -> it should be mentioned there.

Link to comment
Share on other sites

thank you, it's work fine now. really apreciate.

 

once again, when i try to make console connection with ssl. following this tutorial: hxxp://support.eset.com/kb3724/?locale=en_US

when run this command

 

<Connector server="OtherWebServer" port="443" protocol="HTTP/1.1" SSLEnabled="true" maxThreads="150" scheme="https" secure="true" clientAuth="false" sslProtocol="TLS" keystoreFile="/home/eset/tomcat.keystore" keystorePass="yourpassword" keyAlias="tomcat"/>

 

it say: -bash: syntax error near unexpected token `newline'

 

how to get rid of this.

 

thank you.

Edited by macros
Link to comment
Share on other sites

  • ESET Staff

A am not sure I understand you - mentioned configuratoin block:

<Connector server="OtherWebServer" port="443" protocol="HTTP/1.1" SSLEnabled="true" maxThreads="150" scheme="https" secure="true" clientAuth="false" sslProtocol="TLS" keystoreFile="/home/eset/tomcat.keystore" keystorePass="yourpassword" keyAlias="tomcat"/>

has to be written (more precisely existing block has to be modified) into tomcat configuration and not executed in command line.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...