Jump to content

Archived

This topic is now archived and is closed to further replies.

Guest Amy

Personal firewall + browser issues

Recommended Posts

Guest Amy

Hi and thank you for your time and help here,

 

A little history first. I installed the ESET6 trial roughly 2 weeks ago and unfortunately haven't really managed to get the hang of it, or so it seems. From the beginning ESET, for reasons unknown to me, won't recognise any -at all- certificates from websites. This means each time I go to a site I get the 'This Connection is Untrusted' warning and have to manually allow it. I suspect this is due to an error I get, but only sometimes, upon startup, which says, to my memory, that it failed to load or read root certificate for all browsers. (I'll get the exact error next time it occurs.) That's one issue, but a minor one.

 

Sorry, I just realised I don't have time to finish this fully at this moment, but I'll return in a few hours. I can briefly mention that the most important error that has caused me to post here is that when I started up the computer this morning, without any settings having been changed and for reasons I've tried to uncover but can't, the ESET Personal Firewall is preventing me from accessing the Internet. I have turned it off to post this. Normally, when I start a browser it will ask me whether I want to allow the program to access the Internet, this time it simply is denying it automatically.

 

Sorry to post with incomplete info but I am hoping someone will know right away what is going on with the firewall, it is pretty urgent.

Thank you very much for your time.

Amy

Share this post


Link to post
Share on other sites

Hi Amy

Regarding firewall,

 

See the following KB : hxxp://kb.eset.com/esetkb/index?page=content&id=SOLN2843

Follow its instructions to enter the rules section of Smart Security. Step 5. shows a picture of the rules interface.

Please post a screen shot if possible showing us what rules you have setup or not setup.

 

It is my assumption that the mode you selected; see KB article here :
hxxp://kb.eset.com/esetkb/index?page=content&id=SOLN3190&actp=search&viewlocale=en_US&searchid=1377130312219

 

Might be either Automatic mode with exceptions or Interactive mode.

In which you possible inadvertently blocked your own network subnet.

 

Let me know if this helps.

 

:)

Share this post


Link to post
Share on other sites

Regarding Certificates, This usually stems from SSL

You could possibly disable SSL for now, until we get a full explanation of how to set and import certs.

Are you using Internet explorer or firefox, or chrome, etc ?

 

Disable SSL protocol scanning:

  1. Open ESET Smart Security or ESET NOD32 Antivirus.
     
  2. Press F5 to enter Advanced setup.
     
  3. Expand Web and email icon-rarr_10x9.pngProtocol filtering and then click SSL.
     
  4. Select Do not scan SSL protocol and click OK.

 

This is a temp fix till eset staff or someone can give you a good detail on SSL; just to get your errors gone. :)

Share this post


Link to post
Share on other sites
Guest Amy
Thanks Arakasi. To answer your questions, I use alternately Firefox and Opera (Firefox freezes under some circumstances, and due to browser securities doesn't load Flash or media, so I use Opera as a fill-in here and there, as well as to load Gmail which invariably crashes Firefox). I use Interactive Mode, and I would prefer not use Automatic Mode because I prefer knowing that I am in complete control of everything, or anyway as complete as can be, without my being a programmer, using another's software, and so on. Rather than resort to automatic settings in order to make the problem go away I would prefer to properly fix it. And wow, after typing that sentence, something possibly very funny just happened, I just discovered a pop-up that I had dragged away to be nearly invisible in the bottom corner of the screen with just a tiny edge sticking out, because I didn't want it bothering me, not realising that by ignoring that pop-up I would also be simultaneously blocking any further pop-ups from occurring. Well, there was the root of my problem, the pop-up asking me to allow Firefox/Opera access to the internet was prevented from showing. Oh dear me... Well, on goes my Firewall again, so that problem is fixed! Haha.

 

Well, while I am here I may as well look into the other things that have been bothering my a little.

 

What is the problem with certificates/SSL? You're saying the software doesn't know how to import certificates yet, so the problem can't be fixed for now? Or that it can be fixed, but not by your knowledge? While I could have disabled it I have however kept SSL enabled intentionally, because even though I have to manually allow each new page it still affords me a certain level of comfort, knowing that I won't be plunged suddenly into some deny of malice. :)

 

I know there were one or two other minor problems I was having, but I don't remember at the moment what they were, I suppose I'll have to return here and post about them when they recur or I remember. Thanks greatly for your help Arakasi, much appreciated.

Share this post


Link to post
Share on other sites

(Firefox freezes under some circumstances, and due to browser securities doesn't load Flash or media

 

 

Question, you intentionally can't run flash ? or can't get it to install the plugin properly?

Also, do you run a 32bit or 64bit version of Windows ?

 

 

the pop-up asking me to allow Firefox/Opera access to the internet was prevented from showing.

 

Also keep in mind, if you restrict one of your browsers access to the web, you technically still have internet access with an IP assigned from router to your network interface !

I'm sure you realized that and truly meant that in your very first question ! :)

 

 

What is the problem with certificates/SSL? You're saying the software doesn't know how to import certificates yet, so the problem can't be fixed for now? Or that it can be fixed, but not by your knowledge? While I could have disabled it I have however kept SSL enabled intentionally, because even though I have to manually allow each new page it still affords me a certain level of comfort, knowing that I won't be plunged suddenly into some deny of malice. :)

 

The software works just fine, however with some browsers, particularly firefox, the certificate needs to be imported manually.

 

Quote from Marcos:

 

Please be more specific about the versions. If you have Firefox 22 or newer installed, you'll need to export the root certificate from ESS and import it to Firefox TRCA certificate store manually for https websites to open properly. If you have Opera 15 installed, just ignore the message for the time being, SSL scanning will work anyway.

Share this post


Link to post
Share on other sites

Exporting from Eset

Importing to Firefox

 

I hope my picture assists you in locations of options

 

In Firefox, its Tools > Options > Advanced > View certs

In Eset its Setup > Advanced > SSL > Certs > View Cert > Details > Copy to File

 

:)

post-1101-0-14657100-1377142157_thumb.jpg

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...