Jump to content

No Clients in ERA anymore


CowMover
 Share

Recommended Posts

Some days ago I noticed that my ERA 6 Server hasn't any clients anymore. Also nearly every of my 350 clients told me that it isn't able to connect to the server to get updates.

 

After testing around without any result I decidet to update ERA to the newest version. I uninstalled the old ERA Server and installed the newest Version 6.3.136.0. I scanned my Active directory and was able to see all clients again but they are not showing me that they have installed the ERA client and Eset Endpoint Antivirus.

 

I decidet to make a task to update their ERA Agent and Endpoint Antivirus version. The tasks started and show as done without errors but I can't see any result in the task and the clients are also not shown in the webconsole. Some of the clients seem to have the update, some not and some are telling me that they are not able to reach the Eset server - also the one which is directly running on the server.

 

Anyone who has an idea what went wrong and how I can get them back to work?

Link to comment
Share on other sites

  • ESET Staff

Hello, we need the following info to know:

- have you used the Apache HTTP proxy for distributing the updates (have you installed the ERA 6 using all-in-one installer, with the Apache HTTP Proxy option checked)?
- was your ERA server having static IP address?

- have you removed the ERA database, upon performing the upgrade (uninstalling the old one, and installing the new one)? If no, have you connected the new server to the old database?

 

Issue is, that if you have removed the server and DB, regardless the AD sync, agents won´t be able to connect to the new ERA server. First of all, because of the certificates, which won´t be trusted, as they have been created by the previous ERA server (signed by different certification authority). Unless you have the old certificates backed up, you will have to redeploy all agents. In this case, you will have to do it twice, as the first redeployment will do "upgrade" of the agents to the newer version, and second will perfom "repair" and actually update the certificate information to connect to the correct server.

 

PS: What does it mean, that your ERA server hasn´t any clients? Clients were not connecting, or your webconsole was empty without any entries in it? Have you checked the "subgroups" checkbox and selected group all? 

Link to comment
Share on other sites

- I don't have any proxy installed.

- The Era Server has a static IP

- I removed the ERA database, the new server has a completely new database.

 

I have imported the old certificates. Redeploy is not working. If I try to redeploy the agent and Endpoint Security the task shows endet successful but if I look at the details it shows me that nothing is happened.

 

When this issue stared I have not seen any of my clients in the webconsole anymore. Not even a Active Directory rescan brought them back. After installing the new version a Active Directory scan brought them back but they are shown without any Eset product installed.

Link to comment
Share on other sites

When I checked the webconsole some minutes ago, I only found new certificates. So this is where something went wrong. How do I install the old certificates? I installed them in Windows but they are not shown in the webconsole.

Link to comment
Share on other sites

  • ESET Staff

Concerning the server to server migration, you have follow the instructions in the ERA help: hxxp://help.eset.com/era_install/63/en-US/index.html?migration_same_version.htm 

Also, can you please send us screenshot from the "task ended successfully" for the Agent Deployment & Software Installation. As I have mentioned, the deployment task has to be executed twice.

NOTE: Do not redeploy, if you have the certificates, only perfrom steps based on the above help link. Import the public key + change the ERA server certificate in server settings. That should allow your agents to communicate, if the IP / hostname of the new server is the same as it was before (so they are able to reach the server).

Edited by MichalJ
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...