Jump to content

Archived

This topic is now archived and is closed to further replies.

Asgaro

'HTTPS checking' feature blocks outlook.com contacts auto-completion and people.live.com

Recommended Posts

Hi,

 

 

I just noticed the 'HTTPS checking' feature(*) blocks the following from loading:

 

- When composing a new email at outlook.com, the contacts auto-completion window in the To: field doesn't appear.

- people.live.com doesn't load. The loading icon is shown eternally.

 

(*) Location: Advanced setup => Web and email => Web access protection => Web protocols => Enable HTTPS checking.

 

 

I have noticed this on 2 separate systems, both running Windows 10 (one Home, one Pro) and ESET NOD32 Antivirus 9 v9.0.375.0.

Disabling this feature fixes the problem.

 

 

Thought I would let the ESET developers know!

Cheers,

Yen

Share this post


Link to post
Share on other sites

I can also confirm that.  (Windows 10 Pro and Eset AntiVirus 9.0.375)

Share this post


Link to post
Share on other sites

I can also confirm for windows 8.1, windows 10, both running Eset 5.0.2254.1

Share this post


Link to post
Share on other sites

Hello, can you please check which version of the Internet protection module you have?

Share this post


Link to post
Share on other sites

Hello, can you please check which version of the Internet protection module you have?

 

Sure, here you go:

 

Virus signature database: 13256 (20160330)
Rapid Response module: 7751 (20160330)
Update module: 1062 (20151228)
Antivirus and antispyware scanner module: 1481 (20160310)
Advanced heuristics module: 1168 (20160304)
Archive support module: 1247 (20160311)
Cleaner module: 1119 (20160315)
Anti-Stealth support module: 1094 (20160119)
ESET SysInspector module: 1257 (20151113)
Real-time file system protection module: 1010 (20150806)
Translation support module: 1456 (20160222)
HIPS support module: 1219 (20160322)
Internet protection module: 1226.20 (20160323)
Database module: 1078 (20160301)
Configuration module (33): 1240.3 (20160215)
LiveGrid communication module: 1021 (20160310)
Specialized cleaner module: 1010 (20141118)
Rootkit detection and cleaning module: 1000 (20151228)
Network protection module: 1113 (20160330)

Share this post


Link to post
Share on other sites

Virus signature database: 13259 (20160331)
Rapid Response module: 7754 (20160331)
Update module: 1062 (20151228)
Antivirus and antispyware scanner module: 1481 (20160310)
Advanced heuristics module: 1168 (20160304)
Archive support module: 1247 (20160311)
Cleaner module: 1119 (20160315)
Anti-Stealth support module: 1094 (20160119)
ESET SysInspector module: 1257 (20151113)
Real-time file system protection module: 1010 (20150806)
Translation support module: 1456 (20160222)
HIPS support module: 1219 (20160322)
Internet protection module: 1226.15 (20160315)
Database module: 1078 (20160301)
Configuration module (33): 1240.3 (20160215)
LiveGrid communication module: 1021 (20160310)
Specialized cleaner module: 1010 (20141118)
Rootkit detection and cleaning module: 1000 (20151228)
Network protection module: 1114 (20160330)

Share this post


Link to post
Share on other sites

Please try to access the blocked website with pre-release updates. You can do this by following the articles on our website.

How do I enable or disable pre-release updates in my ESET product (Home Users)?
hxxp://support.eset.com/kb3415/

How do I enable pre-release updates (Business Users)?
hxxp://support.eset.com/kb3693/

If the issue still persists, please try disabling SSL/TLS.

You can disable SSL (not recommended) or you can activate SSL in Interactive mode:
Setup > Advanced Setup > Web and Mail > SSL/TLS > Enable SSL/TLS protocol filtering > SSL/TLS protocol filtering mode: Interactive mode.

 

If you disable SSL temporarily and everything works fine at least we know what's causing this. As mentioned before deactivating SSL is not recommended. Interactive mode will ask you if you want to allow or block a website. You can allow the websites that are safe and Ignore the websites that are safe but cause problems.

This part of the manual provides further information on adding certificates manually:
hxxp://help.eset.com/ess/9/nl-NL/index.html?idh_config_epfw_ssl.htm

There is a link List of known certificates that you can use to add the URL of the website for which you want to add the certificate.

If the issue still persists, please open a support ticket (click Support on the ESET website and create a ticket).

Share this post


Link to post
Share on other sites

Been testing an internal version of the Internet protection module 1226.25 for a while and didn’t encounter any issues with the address autocomplete feature when composing an email at outlook.com. We're now working on a ultimate fix so if everything goes well, the new module (probably 1226.26) will be put on pre-release update servers tomorrow.

Share this post


Link to post
Share on other sites

I enabled pre-release updates (and cleared update cache and restarted PC, as recommended).

The issue still persists on the currently available Internet protection module 1226.24.

 

I look forward to testing 1226.26.

Share this post


Link to post
Share on other sites

Internet protection module 1226.26 is already available on pre-release servers.

Share this post


Link to post
Share on other sites

Internet protection module 1226.26 is already available on pre-release servers.

 

This version indeed fixed it. Thanks!

Share this post


Link to post
Share on other sites

WIN 7 - same issue - "People" page not loading -  the workarounds

I see here seem over my expertise level - is there a magic pill to

get this functional again?

Share this post


Link to post
Share on other sites

It's really odd as I'm able to access this page even with the option to exclude the communication with trusted domains disabled as you can see below. Tested with Firefox 45.0.1 on Windows 10 x64 build 10586:

post-10-0-36209600-1460020750_thumb.png

 

 

Virus signature database: 13297P (20160407)
Rapid Response module: 7796 (20160407)
Update module: 1064 (20160324)
Antivirus and antispyware scanner module: 1482 (20160330)
Advanced heuristics module: 1168 (20160304)
Archive support module: 1248 (20160329)
Cleaner module: 1120 (20160401)
Anti-Stealth support module: 1095 (20160310)
Personal firewall module: 1304B (20160224)
ESET SysInspector module: 1257 (20151113)
Real-time file system protection module: 1012 (20151124)
Translation support module: 1464 (20160315)
HIPS support module: 1222 (20160331)
Internet protection module: 1226.26 (20160405)
Web content filter module: 1046.1 (20151202)
Advanced antispam module: 3499P (20160407)
Database module: 1078 (20160301)
Configuration module (33): 1240.4 (20160406)
LiveGrid communication module: 1021 (20160310)
Specialized cleaner module: 1012 (20160405)
Banking & payment protection module: 1061 (20160323)
Rootkit detection and cleaning module: 1001 (20160310)
Network protection module: 1122 (20160406)

Share this post


Link to post
Share on other sites

Marcos, if I understand it correctly: ESET whitelists some SSL/TLS websites by default so they do not get checked using the ESET SSL Filter CA.

 

Because I noticed, for example, that (with Internet protection module 1226.26) gmail.com seems to be whitelisted since the certificate says: Issued by: Google Internet Authority G2 (No mention of ESET).

While, for example, on forum.eset.com it says: Issued by: ESET SSL Filter CA.

 

So if I understand correctly, in Internet protection module 1226.26 you also whitelisted people.live.com since on my system it says: Issued By: Symantec Class 3 EV SSL CA - G3 (No mention of ESET).

 

-----------------------------

 

But looking at your screenshot, I see you use Firefox and can access people.live.com even WITH Issued by: ESET SSL Filter CA.

Could you please try the 64 bits version of Google Chrome? Since that's what I use.

 

-----------------------------

 

Btw, I installed Firefox 64 bits and I have the same results as I was having with Chrome 64 bits:

- gmail.com: Issued by: Google Internet Authority G2 (No mention of ESET).

- forum.eset.com: Issued by: ESET SSL Filter CA.

- people.live.com: Issued By: Symantec Class 3 EV SSL CA - G3 (No mention of ESET).

Share this post


Link to post
Share on other sites

Ah, I get it now:

 

I now also disabled 'Exclude communication with trusted domains' and restarted my PC.

 

Results:

- gmail.com: works fine and shows Issued by: ESET SSL Filter CA.

https://dl.dropboxusercontent.com/u/2648/ESET/gmail.PNG

- people.live.com: works fine and shows Issued by: ESET SSL Filter CA BUT

https://dl.dropboxusercontent.com/u/2648/ESET/live.PNG

Note it says something different here. I don't know if that can be related...

 

 

 

-------------

 

But to summarize: it seems the issue is solved in 1226.26, isn't it?

Share this post


Link to post
Share on other sites

But to summarize: it seems the issue is solved in 1226.26, isn't it?

 

Yes, should be.

Share this post


Link to post
Share on other sites

the workarounds I see here seem over my expertise level

 

But this KB article hxxp://support.eset.com/kb3415 explains it step by step. How can this be over your expertise level? :-o

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...