Jump to content

Archived

This topic is now archived and is closed to further replies.

girts.u

Simultaneous connection count

Recommended Posts

Hi there

 

We were experiencing the same issue, where the last connected was stopping for all agents.

Made the change as mentioned above " add innodb_lock_wait_timeout=600 to your MySQL configuration (/etc/my.cnf) into [mysqld] section"

This seemed to have fixed the issue, but now it seems to have only extended the time before the agents again fail to show the updated connection time

 

Anything else we can try?

Share this post


Link to post
Share on other sites

Hi there

 

We were experiencing the same issue, where the last connected was stopping for all agents.

Made the change as mentioned above " add innodb_lock_wait_timeout=600 to your MySQL configuration (/etc/my.cnf) into [mysqld] section"

This seemed to have fixed the issue, but now it seems to have only extended the time before the agents again fail to show the updated connection time

 

Anything else we can try?

 

Proper value depends on number of clients you are managing, amount of collected data and overall performance of MySQL database. In case value 600 is not enough, you may increase it (maybe to 3600).

Also have you checked whether multi-threading is enabled for your MySQL driver (/etc/odbcinst.ini)?

Share this post


Link to post
Share on other sites

thanks for the reply

 

have upped the timeout to 3600, so will keep an eye on it

 

this link (hxxp://help.eset.com/era_install/63/en-US/index.html?odbc_configuration.htm) says my version on MySQL (5.3) supports multithreading

 

but do I need to add this line aswell?

 

Threading = 0

 

as per above link

 

fyi, we are only dealing with <100 clients

Share this post


Link to post
Share on other sites

but have found this in the trace.log

 

Warning: CDatabaseModule [Thread 7f89e899e700]: Dependability checks of underlaying layer failed with:
The underlying unixodbc implementation has not support for multithreading.

 

also

 

contents of odbcinst.ini

 

[PostgreSQL]
Description             = ODBC for PostgreSQL
Driver          = /usr/lib/psqlodbc.so
Setup           = /usr/lib/libodbcpsqlS.so
Driver64                = /usr/lib64/psqlodbc.so
Setup64         = /usr/lib64/libodbcpsqlS.so
FileUsage               = 1

[MySQL ODBC 5.3 Unicode Driver]
Driver          = /usr/lib64/libmyodbc5w.so
UsageCount              = 1

[MySQL ODBC 5.3 ANSI Driver]
Driver          = /usr/lib64/libmyodbc5a.so
UsageCount              = 1

Share this post


Link to post
Share on other sites

thanks for the reply

 

have upped the timeout to 3600, so will keep an eye on it

 

this link (hxxp://help.eset.com/era_install/63/en-US/index.html?odbc_configuration.htm) says my version on MySQL (5.3) supports multithreading

 

but do I need to add this line aswell?

 

Threading = 0

 

as per above link

 

fyi, we are only dealing with <100 clients

 

Yes, you should enable multi-threading. It is not only due to performance, but also for certain functionality that requires it - for example canceling SQL queries that are no longer required.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...