Jump to content

ERA6.3 Installation failed


sdnian
 Share

Recommended Posts

I've backup ERA 6.2 database from another to a new server. And I've installed SQL Express manul and restore database into it. Then I run 'Setup.exe' to install ERA 6.3, but uncheck 'Microsoft SQL Server Express'. it always show 'Installation failed. Do you want to installed components?'. What's wrong? I've do it many times in ERA 6.2, it all work well. Why ERA 6.3 can't do it with the same procedure?

 

 

post-990-0-43613300-1453619650_thumb.pngpost-990-0-00690100-1453619659_thumb.png

InstallReport.htmlServer_x64.msi.logServerUninstall.log.txt

Link to comment
Share on other sites

  • ESET Staff

There seems to be problem with authentication into cloned database:

[Microsoft][ODBC SQL Server Driver][SQL Server]Login failed for user 'era_user'

have you migrated also DB user era_user? There has been some changes in this phase of installation (reducing required permissions) and it seems user is no longer automatically created in case you are installing ERA using existing database.

Link to comment
Share on other sites

There seems to be problem with authentication into cloned database:

[Microsoft][ODBC SQL Server Driver][SQL Server]Login failed for user 'era_user'

have you migrated also DB user era_user? There has been some changes in this phase of installation (reducing required permissions) and it seems user is no longer automatically created in case you are installing ERA using existing database.

 

I backup and restore DB from another to the new one. Then I drop 'era_user' account before installing ERA 6.3. But I always get failed message. I also try to keep 'era_user' account, then install ERA 6.3. But I got the same error message. So could you please tell me what is the right procedure if I'd like to migrate DB from another server to new one? Thank you.

Link to comment
Share on other sites

  • ESET Staff

 

There seems to be problem with authentication into cloned database:

[Microsoft][ODBC SQL Server Driver][SQL Server]Login failed for user 'era_user'

have you migrated also DB user era_user? There has been some changes in this phase of installation (reducing required permissions) and it seems user is no longer automatically created in case you are installing ERA using existing database.

 

I backup and restore DB from another to the new one. Then I drop 'era_user' account before installing ERA 6.3. But I always get failed message. I also try to keep 'era_user' account, then install ERA 6.3. But I got the same error message. So could you please tell me what is the right procedure if I'd like to migrate DB from another server to new one? Thank you.

 

 

We have been trying to find at least workaround, but unfortunately we were not successful -> all-in-one installer was expected to be used for clean installations and mentioned scenario was not considered (nor tested), therefore newly introduced changes broke it. Currently only migration of DB to new server, but without re-installing ERA Server is supported, as described in documentation: hxxp://help.eset.com/era_install/63/en-US/db_migration_sql.htm.

 

You could possibly install ERA Server and other components manually.

 

Could you please provide more details or reason why are you migrating whole ERA installation to different server?

 

 

 

Could you please

Link to comment
Share on other sites

If ERA 6.3 can't support re-installing ERA Server, when original ERA Server crash.. I've create a whole new server. How can I recover a new ERA Server that does not lose any setting? I mean that I've backup original ERA Server DB before ERA server crashed.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...