Jump to content

Archived

This topic is now archived and is closed to further replies.

wolliballa

Failure to add root certificate to all known browsers ( 9.0.349, W10-1511)

Recommended Posts

I had hoped the issue would be solved, but I am still getting an error message 'adding root cerificate to all known browsers failed' after every reboot.
System:
W10-64 ( Version 1511, fully updated)
Firefox latest rev

NOD32 9.0.349.15

 

 

Besides that there are no error messages or operational issues.

Can someone clarify ?

post-1117-0-22218000-1452726802_thumb.png

Share this post


Link to post
Share on other sites

Please continue as follows:

- download Process monitor and ESET Log Collector

- disable SSL scanning

- restart the computer (do not open any applications)

- start logging with Process monitor

- re-enable SSL scanning

- if the error occurs, stop logging

- compress the Process monitor log, collect logs using ESET Log Collector and supply it to me via a pm (if the log is too large to submit, upload it to a safe location and pm me just a download link).

Share this post


Link to post
Share on other sites

Same Problem here on 2 Installations of Windows 7 x64 Home Premium (german). Both Installations are M$ & 3rd party Software fully up to date.

 

On 3 additional Windows 7 Installations (2 Professional & 1 Ultimate, all x64) the problem doesn't occure.

 

If the threadtarter's os is a home edition too, this might be something to look in...

 

No solution yet but I'm gonna try disabling scanning of SSL to see whether the warning disappears or not. If so procmon's gonna be checked...

Share this post


Link to post
Share on other sites

Solution (in my special case):

 

disabling "add certificate to browser" removed the warning only...

 

After investigating with procmon I found entries from "certimporter-1299.exe" wich was unable to find the Mozilla Firefox Profile's path... (This seemed to occure because the user's name contained a blank and a special german character (ä)). Moving the firefox profile to a path without problematic characters or blanks by editing the profiles.ini solved the problem entirely...

 

So, it wasn't the home edition...

 

THX for the advice "procmon"...

 

CYA all,

 

NHD

Share this post


Link to post
Share on other sites

Please upload the Procmon log to a safe location and pm me the download link. I'd like to check it out myself as I was unable to reproduce the issue with a profile name containing spaces and German special characters.

Share this post


Link to post
Share on other sites

Just to clarify: Wouldn't it be necessary to make sure process monitor starts up first after reboot? As import of cerificate fails, there will be no other 'retry' to monitor.  The issue immediately occurs when user desktop gets ready.
Could also be a timing issue as machine in question is 8MB, Fast I5 and SSD only.

Will see whether datacollection is possible over the weekend.

Share this post


Link to post
Share on other sites

So the error doesn't occur if you disable SSL scanning (with browsers and email clients closed), click OK and then re-enable it? The root certificate is added upon system startup only if the operation failed before.

Share this post


Link to post
Share on other sites

@ Marcos:

You got a pm...

Share this post


Link to post
Share on other sites

Process monitor log done.

How long would you think would it take to create a sysinspector log on a fast I5 SSD-Only system ( 1Day events only)? (all other collection tasks were done within seconds)

It hasn' finished even after 15 minutes so I cancelled further execution.

However I can reproduce the problem. Immediately after re-enabling SSL-scanning the error message occurs.

And my user name in firefox profile does not contain any spaces or special characters.

 

Pls. advise how long I should wait.....
I can re-do the exercise (basically) any time.

Share this post


Link to post
Share on other sites

Try unselecting SysInspector log in ESET Log Collector's gui and create one from your ESET NOD32 Antivirus.

Share this post


Link to post
Share on other sites

Is there a fix for this yet? I have just bought ESET Smart Security 9 after having issues with Norton giving a BSOD. I get the same error as above upon startup

I use Win 10 64bit and mainly Chrome. If I click OK the error removes does not come back until I next load the PC up

Share this post


Link to post
Share on other sites

Is there a fix for this yet? I have just bought ESET Smart Security 9 after having issues with Norton giving a BSOD. I get the same error as above upon startup

I use Win 10 64bit and mainly Chrome. If I click OK the error removes does not come back until I next load the PC up

 

Having the same issue here on a Dell Studio XPS 8100 with a fresh install of NOD32 9.0.349 over NOD32 8 on Win7 Home Premium SP1 64-bit.

 

I got the error during the installation of v9 and now also at each start up. I'm running Firefox 44.0.2 and IE11 with all the latest updates, no other browsers.

 

On a Thinkpad X230 I also upgraded v9 over v8 and I'm running the same browsers and versions and do not get this error.

 

EDIT - I should add that I'm running No Script in Firefox on both the Dell and the ThinkPad, I get the error on the Dell but not on the ThinkPad.

Share this post


Link to post
Share on other sites

Kindly put SSL/TLS mode to learning mode and check.

Share this post


Link to post
Share on other sites

Having the same issue on several clients here in Denmark:

 

Lenovo Thinkcentre

HP Elitebook

HP Probook

 

Windows 7 fully updated 

Chrome latest

IE latest

ESET AV 9.0.349.15

 

Just upgraded from version 8.

 

Regards from Mads

Share this post


Link to post
Share on other sites

I have German version with 'automatic', 'interactiv' and 'Police mode. Not sure what you meant.

Anyway in interactive and policy mode I haven't seen error msg, but Thunderbird no longer connects to secured mailservers as set up.

Share this post


Link to post
Share on other sites

Please follow the instructions from my post above:

 

- download Process monitor and ESET Log Collector

- disable SSL scanning

- restart the computer (do not open any applications)

- start logging with Process monitor

- re-enable SSL scanning

- if the error occurs, stop logging

- compress the Process monitor log, collect logs using ESET Log Collector and supply it to me via a pm (if the log is too large to submit, upload it to a safe location and pm me just a download link).

To wolliballa: I forgot to reply that instead of a Procmon log you provided me with the Procmon executable.

Share this post


Link to post
Share on other sites

I have same error popping up after every reboot. I have tried disabling and enabling settings, no avail.

Latest win7 64, latest browsers, using Eset NOD32 Antivirus.

 

Problem started after upgrading from version 8 to 9.

Share this post


Link to post
Share on other sites

I too have this issue. Newly built Windows 10 Pro machine....installed Firefox and then ESET Smart Security  9.0.349 and this error now pops up on every boot. it does disappear if I disappear if I disable SSL scanning.I am hoping I have correctly managed to collect a log and will send it via pm to Marcos as well

Share this post


Link to post
Share on other sites

Guys..I put SSL / TLS filtering into interactive mode...accepted all the scan questions as they came up at boot ( said Ok to scan) and then waited about 5 minutes, rebooted and put the filter mode back to automatic and it no longer starts with the error. Thanks Marcos for reply. Not sure what the real answer was for this but issue has gone for me at least.

Share this post


Link to post
Share on other sites
@TeMorituriSalutamus :

Thanks, your suggestion fixed it.

I now tried with update to 9.0.375.1 on W10-64. Changing SSL setting afterwords. Reboot. All OK.

Problem appears to be fixed both on W10-64 / W7-64

Share this post


Link to post
Share on other sites

Guys..I put SSL / TLS filtering into interactive mode...accepted all the scan questions as they came up at boot ( said Ok to scan) and then waited about 5 minutes, rebooted and put the filter mode back to automatic and it no longer starts with the error. Thanks Marcos for reply. Not sure what the real answer was for this but issue has gone for me at least.

 

Just so I understand . . . is this correct?

 

1. put SSL / TLS filtering into interactive mode

 

2. reboot PC   (not just restart ESET NOD32)

 

3. accept all the scan questions as they come up after reboot PC

 

4. wait about 5 minutes, then reboot PC again   (not just restart ESET NOD32 again)

 

5. put the SSL / TLS filtering mode back to automatic

 

Thanks!  :)

Share this post


Link to post
Share on other sites

With v9 it's not necessary to switch to interactive mode. Just open the list of known certificates, double-click the appropriate one and then choose the desired action.

Share this post


Link to post
Share on other sites

@ Opti Yes ..that is eaxctly what I did and the problem has not returned since then.

 

I dont think I even had the original/known certificates for some reason so could not have folllowed Marcos advice above (brand new Windows 10 Pro x64 machine)

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...