Jump to content

Migration from 5.x to 6.x - unable to export old database


xbures
 Share

Recommended Posts

I have the Eset ERA server 5.2.26 on the Windows Server 2008 R2. I would like to upgrade the ERA version to 6 using the Migration tool. I had installed all prerequisities (C++ and MS Hotfix) and would like to export database 5.2.26 via migration tool.

 

After choosing the export database check box and click on the Next buton, there are the error message "Unable to stop RemoteAdministrator service". I tried to stop it via the ERA maintenance tool, it works, but after the choosing what data could be exported there was next error message - cannot connect to database. 

 

Have you any idea? Thank you.

Link to comment
Share on other sites

I have the Eset ERA server 5.2.26 on the Windows Server 2008 R2. I would like to upgrade the ERA version to 6 using the Migration tool. I had installed all prerequisities (C++ and MS Hotfix) and would like to export database 5.2.26 via migration tool.

 

After choosing the export database check box and click on the Next buton, there are the error message "Unable to stop RemoteAdministrator service". I tried to stop it via the ERA maintenance tool, it works, but after the choosing what data could be exported there was next error message - cannot connect to database. 

 

Have you any idea? Thank you.

 

Did you test v6 before?

Link to comment
Share on other sites

 

I have the Eset ERA server 5.2.26 on the Windows Server 2008 R2. I would like to upgrade the ERA version to 6 using the Migration tool. I had installed all prerequisities (C++ and MS Hotfix) and would like to export database 5.2.26 via migration tool.

 

After choosing the export database check box and click on the Next buton, there are the error message "Unable to stop RemoteAdministrator service". I tried to stop it via the ERA maintenance tool, it works, but after the choosing what data could be exported there was next error message - cannot connect to database. 

 

Have you any idea? Thank you.

 

Did you test v6 before?

 

No

Link to comment
Share on other sites

 

 

I have the Eset ERA server 5.2.26 on the Windows Server 2008 R2. I would like to upgrade the ERA version to 6 using the Migration tool. I had installed all prerequisities (C++ and MS Hotfix) and would like to export database 5.2.26 via migration tool.

 

After choosing the export database check box and click on the Next buton, there are the error message "Unable to stop RemoteAdministrator service". I tried to stop it via the ERA maintenance tool, it works, but after the choosing what data could be exported there was next error message - cannot connect to database. 

 

Have you any idea? Thank you.

 

Did you test v6 before?

 

No

 

 

May I suggest that you test before going to production? v6 is so much different from v5 that it's not just simple upgrade.

Link to comment
Share on other sites

 

 

 

I have the Eset ERA server 5.2.26 on the Windows Server 2008 R2. I would like to upgrade the ERA version to 6 using the Migration tool. I had installed all prerequisities (C++ and MS Hotfix) and would like to export database 5.2.26 via migration tool.

 

After choosing the export database check box and click on the Next buton, there are the error message "Unable to stop RemoteAdministrator service". I tried to stop it via the ERA maintenance tool, it works, but after the choosing what data could be exported there was next error message - cannot connect to database. 

 

Have you any idea? Thank you.

 

Did you test v6 before?

 

No

 

 

May I suggest that you test before going to production? v6 is so much different from v5 that it's not just simple upgrade.

 

I have no test environment and this is relativelly small client, there are only 40 eset clients and I have no politics or some jobs on ERA. I use it about 8 months (version 5). It could be possible to deinstall version 5 without any backup and install the version 6, but I want to try the migration process on this small client. 

Link to comment
Share on other sites

Having the same issue but in my scenario its different
 
Migration from 5.x to 6.x  unable to import file.
 i'm getting the error shown in the picture.

post-8497-0-52400300-1448539842_thumb.jpg

Link to comment
Share on other sites

 

 

 

 

I have the Eset ERA server 5.2.26 on the Windows Server 2008 R2. I would like to upgrade the ERA version to 6 using the Migration tool. I had installed all prerequisities (C++ and MS Hotfix) and would like to export database 5.2.26 via migration tool.

 

After choosing the export database check box and click on the Next buton, there are the error message "Unable to stop RemoteAdministrator service". I tried to stop it via the ERA maintenance tool, it works, but after the choosing what data could be exported there was next error message - cannot connect to database. 

 

Have you any idea? Thank you.

 

Did you test v6 before?

 

No

 

 

May I suggest that you test before going to production? v6 is so much different from v5 that it's not just simple upgrade.

 

I have no test environment and this is relativelly small client, there are only 40 eset clients and I have no politics or some jobs on ERA. I use it about 8 months (version 5). It could be possible to deinstall version 5 without any backup and install the version 6, but I want to try the migration process on this small client. 

 

 

 

It does not matter if you have 5 or 50 clients. The philosophy of v6 is so much different that you might stumble on large number of problems.

If you don't have complex policy in v5 you might be better with clean install. But even then, you will encounter many problems.

You should setup virtual environment and try testing, and then decide. You won't regret time spent on test.

Link to comment
Share on other sites

 

 

 

 

 

I have the Eset ERA server 5.2.26 on the Windows Server 2008 R2. I would like to upgrade the ERA version to 6 using the Migration tool. I had installed all prerequisities (C++ and MS Hotfix) and would like to export database 5.2.26 via migration tool.

 

After choosing the export database check box and click on the Next buton, there are the error message "Unable to stop RemoteAdministrator service". I tried to stop it via the ERA maintenance tool, it works, but after the choosing what data could be exported there was next error message - cannot connect to database. 

 

Have you any idea? Thank you.

 

Did you test v6 before?

 

No

 

 

May I suggest that you test before going to production? v6 is so much different from v5 that it's not just simple upgrade.

 

I have no test environment and this is relativelly small client, there are only 40 eset clients and I have no politics or some jobs on ERA. I use it about 8 months (version 5). It could be possible to deinstall version 5 without any backup and install the version 6, but I want to try the migration process on this small client. 

 

 

 

It does not matter if you have 5 or 50 clients. The philosophy of v6 is so much different that you might stumble on large number of problems.

If you don't have complex policy in v5 you might be better with clean install. But even then, you will encounter many problems.

You should setup virtual environment and try testing, and then decide. You won't regret time spent on test.

 

O.k., I try it. I have many clients on version 5 and they will need upgrade in a future  

Link to comment
Share on other sites

  • 3 months later...

Im facing the same issue here and even if I stop the Remote Administrator service manually and proceed we get the generic error (Error Connecting to the Databse).

 

Is there a solution to this issue???

Link to comment
Share on other sites

  • 4 months later...

Hello xbures,

 

Bbahes has a good point. Upgrading from Remote Administrator 5 to 6 is a decision that should not be taken lightly. It is imperative that you familiarize yourself with the differences between both versions as version 6 introduces a completely new architecture compared to earlier versions of ERA. Please install ESET Remote Administrator 6 on a (virtual) test machine and have a look at the new interface and its features. When upgrading from version 5 to 6 you should do it for all machines (workstations, servers, Remote Administrator, the whole shebang). Please have a look at the following article:

 
ESET Remote Administrator 6 - FAQ / what's new?

 

And now regarding your question:

 

- did you follow the manual?

hxxp://help.eset.com/era_install/63/en-US/index.html?migration_tool.htm

 

- Is the v5 a default installation or some tweaking with ports, etc.?

 

- User permissions?
 
- Do you have any complex policies in v5? If not you may want to consider a clean install?
 
Hope this helps...
Link to comment
Share on other sites

  • 2 weeks later...

Hi. I have the same issue with the migration tool (cannot connect to database). Is there any *real* solution to this problem? (no, I don't consider the suggestion of trying v6 before upgrading, a solution).

Link to comment
Share on other sites

Hi. I have the same issue with the migration tool (cannot connect to database). Is there any *real* solution to this problem? (no, I don't consider the suggestion of trying v6 before upgrading, a solution).

+1 for me.  This needs a real solution.  ESET support, you guys are normally right on the ball with this sort of stuff; please help out.

TIA

Link to comment
Share on other sites

Hi. I have the same issue with the migration tool (cannot connect to database). Is there any *real* solution to this problem? (no, I don't consider the suggestion of trying v6 before upgrading, a solution).

 

Testing environment is not meant to be problem solver. Best of luck if you are deploying software without deploying test environment.

Link to comment
Share on other sites

Come on, guys! The Migration Tool works fine for thousands of customers. Yes, it may not work for everyone, there may be environmental issues ESET just can't know about...

 

Just. Do. A. Clean. Install. :)

 

It will allow you to familiarize yourself with the latest version. You will thank me for this afterwards. :)

Link to comment
Share on other sites

  • 1 month later...

I'm sorry, but this is ridiculous.

 

OP: I'm having a specific error while using the v6 migration tool

Response: Did you test version 6 to make sure you like it?

 

OP: No, but sure maybe I'll test it out

Response: (Continued talk of how different version 6 is)

 

Then finally, another response other than just talking about how different the new version is appears, only to basically say RTFM, and then finally recommends just doing a clean install.

 

Seriously?  This is a question about a *specific* error that is very clearly presented simply by running the migration tool and trying to do a simple export of v5 configuration data.

 

Oh, by the way.  I am getting this error too.  And no, I haven't run a test virtual environment for 6 months with a new version before simply attempting to export configuration data from the old version.  And yes, I have read the instructions completely.  And no, I don't have some complex environment or a huge number of clients.  If I have to do a clean install it's not the end of the world, but this is very unprofessional to have no working upgrade path.

Link to comment
Share on other sites

  • 4 months later...
  • ESET Staff

You may want to open support ticket for this.

- in MigrationTool log files there should be more information why database connection failed. This is most likely due to priviledges (tool did not require Administrative priviledges by manifest, and same database framework is used as ERAV5 had - despite being not so programmer friendly - to avoid database connectivity issues)

 

Anyway logs would tell me most, they are generated next to tool (migration.log).

Seeing the picure we did not provide link to a log file in fatal error screen, this will be remedied (doh)...

 

As a sidenote new tool for V5=>V6 migration is in progress, so noticing this I'm going to revive this old thread in hope of feedback... (and possibly fix this as this issue never reached me in 3 years this tool is out)

Edited by LegacyConnectorSupport
Link to comment
Share on other sites

  • 2 months later...

Launch the migration tool as administrator. Solved this same issue for me today.

Their how-tos are buggy. You have to fly by the seat of your pants sometimes. For example, the pre-reqs say C++ 2010, when they should have said 2015.

I'm in the process of upgrading to 6 from 5 because it's the only way to help with stuff like WannaCry. I've been putting this off for 3 years; now I'm forced to upgrade. I may still end up doing a clean install, we'll see.

Link to comment
Share on other sites

  • 1 month later...
On 2/25/2017 at 4:58 PM, LegacyConnectorSupport said:

You may want to open support ticket for this.

- in MigrationTool log files there should be more information why database connection failed. This is most likely due to priviledges (tool did not require Administrative priviledges by manifest, and same database framework is used as ERAV5 had - despite being not so programmer friendly - to avoid database connectivity issues)

 

Anyway logs would tell me most, they are generated next to tool (migration.log).

Seeing the picure we did not provide link to a log file in fatal error screen, this will be remedied (doh)...

 

As a sidenote new tool for V5=>V6 migration is in progress, so noticing this I'm going to revive this old thread in hope of feedback... (and possibly fix this as this issue never reached me in 3 years this tool is out)

I just tried to run migration tool as administrator, and it works.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...