Jump to content

Windows 10, eset 9, HIPS


Go to solution Solved by ftracy3,

Recommended Posts

I was having an issue with eset 8 not enabling HIPS and thought the upgrade to 9 might fix it (I upgraded tonight using the online installer). It didn't. HIPS is marked red and "non-functional" although "Enable HIPS" is checked on the settings page. Checking and unchecking that box triggers a "user rules file contain invalid data" warning after the "allow this program?" prompt from Windows. I am not on a prerelease/beta version of Windows. I have Windows 10 Pro version 1511 OS build 10586.11. Eset Smart Security 9.0.318.0 Any suggestions to get this working?

Link to comment
Share on other sites

Additional info: When I manually disableHIPS in setup and reboot--on the ESET home page I get the big warning about computer being unprotected when I open Eset. If I reenable HIPS and reboot, I no longer get that immediate warning, just a red number 1 next to Setup and the HIPS slider disabled on the Setup page but enabled on the corresponding settings page gear link. The Home page shows "You are protected" even though I'm getting conflicting info from Setup/HIPS activation.

Link to comment
Share on other sites

HIPS support module version 1200.1 (20151103).

If I recall correctly the problem began after the major Windows 10 update a couple of weeks ago (in eset 8) and has continued with eset 9 since installation yesterday.

Link to comment
Share on other sites

  • Administrators

HIPS module 1200.1 should be available only to v5 users. All other users have HIPS 1206 available and it's also available on pre-release servers regardless of the version of the ESET product you have.

Link to comment
Share on other sites

Any idea why an upgrade to v9 yesterday wouldn't install the latest HIPS module? Is there a way to fix this? I guess I could try uninstalling and reinstalling completely? I'd prefer not to because re "learning" all my wireless streaming stuff is a pain.

Edited by ftracy3
Link to comment
Share on other sites

Well, I tried replacing the ekernhips .dll in safe mode as suggested in eset support kb2891--that completely removed HIPS as even existing in any of the menus and the only new alert was about the banking protection. replaced the old .dll back and back to the same issue. If I can't resolve this I may have to switch to another program, which would be a shame as I like eset a lot.

Link to comment
Share on other sites

  • Solution

Solved..for now. I enabled prerelease updates for ESET and also installed the latest Windows update (not sure which did the trick). anyway HIPS now shows as active.

Link to comment
Share on other sites

I have windows 10 release build 10240 and ess9 w/HIPS 1206. I was forces to revert from the threshold 2 update, because the upgrade borked my OS, I upgraded from ess 8 to 9 after upgrading to threshold 2, so when I reverted back to 10240, ESS got uninstalled. so had to install ess 9 again, but I am getting the invalid rules error from hips now. I already told ESS setup to repair my install once, but nothing seems to have changed.

Link to comment
Share on other sites

i finally got the issue resolved although the way it resolved it self is strange, and I don't know why it worked. I had to do a repair install of win10 pro 10240 for other reasons, but during the black percentage screen of windows setup something went awry and the install undid what it was doing. when windows loaded up again, the HIPS driver suddenly started working. I don't know why or how windows setup would cause he malfunctioning HIPS driver to start working, but whatever.....

Edited by cybot
Link to comment
Share on other sites

Solved..for now. I enabled prerelease updates for ESET and also installed the latest Windows update (not sure which did the trick). anyway HIPS now shows as active.

 

Where did you enable the prerelease updates for ESET ? I don't see that setting.

Link to comment
Share on other sites

  • ESET Insiders
Where did you enable the prerelease updates for ESET ? I don't see that setting.

 

Go into Advanced setup -> Update -> Basic and toggle the Update type.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...