Jump to content

Missing IP addresses of clients in ERA main panel


Recommended Posts

Some of my clients are not reporting their IP address on computer panel in ERA.

When I check network card section in computer details, there is a valid IP address shown but why it isnt on global panel ? 

Its usefull for searching for duplicates with changed names or missing clients and its important for me.

Link to post
Share on other sites

I have devices that do this. It doesn't really impact my work or reporting, but it is kind of annoying. I only have this on OS X devices running 10.11.1 (El Capitan) and version 6.1.16 of EEA and 6.2.166 of ERA.

 

I only have three OS X devices that upgraded to El Capitan and it only affects these three devices. Older versions of OS X report fine and it does not affect Windows or Linux at all either.

Link to post
Share on other sites

In my LAN 20 clients out of 150 doesnt report their IP address.

All of them have agent version 6.2.190 installed and Windows OS (XP,Vista, 7, 8.1 and 10) in both 32 and 64 bit version so no rule here.

Link to post
Share on other sites

I see this since Agent version 6.2.11.0 on almost all notebooks or PC's with multiple network adapters. On some PC's it can be fixed by moving active connection to top in connections list how they are accessed by network services (Press Alt key in Network Connections, Advanced -> Advanced Settings...), but that's only workaround, not a solution.

Link to post
Share on other sites

I see this since Agent version 6.2.11.0 on almost all notebooks or PC's with multiple network adapters. On some PC's it can be fixed by moving active connection to top in connections list how they are accessed by network services (Press Alt key in Network Connections, Advanced -> Advanced Settings...), but that's only workaround, not a solution.

Like You said, its not a solution but walkaround, but i tried that on computer i have access to right now.

I moved that connection to the first place on list u were talking about. Then i removed that client from ERA.

After some time computer showed again on ERA panel without IP address :/

So even that didn't work for me.

Link to post
Share on other sites

I've checked more and it seems my "workaround" is working only on Windows 7... You don't need to remove client from ERA, only to restart agent on PC and after second Agent sync, IP will appear in ERA panel.

Link to post
Share on other sites

I've checked more and it seems my "workaround" is working only on Windows 7... You don't need to remove client from ERA, only to restart agent on PC and after second Agent sync, IP will appear in ERA panel.

Restarting the agent after changing order of connections did the trick but sadly i dont have access to all computers with that problem :/

Eset never had problems with getting IP address till now.

Link to post
Share on other sites
  • ESET Staff

Hello, you have most probably experienced one of issues in ERA 6.2 which caused IP to be not displayed in case of:

  • primary / first adapter is not IPv4 or IPv6 ethernet connection (i.e. it does not work for VPN, PPP and other adapters). Workaround is to reorder network interfaces on client as you already found out
  • client is using IPv6 and IPv4 is disabled or has no IP address assigned (i.e. it is IPv6 only environment)

Both issues should be addressed in upcoming release. Until that you can either use "reordering" workaround, or create custom report (report template) which will show the same IP addresses as are available in client details.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...