Jump to content

Recommended Posts

  • Administrators

Please be more specific about the versions. If you have Firefox 22 or newer installed, you'll need to export the root certificate from ESS and import it to Firefox TRCA certificate store manually for https websites to open properly. If you have Opera 15 installed, just ignore the message for the time being, SSL scanning will work anyway.

Link to comment
Share on other sites

Guest Case793

How do I export the root certificate and import it to Firefox? Because when I copied the certificate (.cer-file) it was only possible without the private key. When I tried to import it to Firefox I was asked for a password which I don't have.

Link to comment
Share on other sites

  • 2 weeks later...

solved the problem Thanks Bro  :D

 

How do I export the root certificate and import it to Firefox? Because when I copied the certificate (.cer-file) it was only possible without the private key. When I tried to import it to Firefox I was asked for a password which I don't have.

Can we get detailed instructions on how to export and import the eset certificate in firefox?

Link to comment
Share on other sites

  • 3 months later...

I have the same problem, I like to use Firefox for everything but SSL just is not working as the above issue says.  How do we export and import it so it works?  I have tried but when I search for something on Google it asks me everytime about the "Certificate Risk"  When is EST going to fix this?

Link to comment
Share on other sites

It seems to only happen with GOOGLE search?  If I change the Search Engine to Yahoo it works? How do we get it to work with GOOGLE? Tell I lie it just happened here too?

Link to comment
Share on other sites

  • Administrators

First of all, enabling SSL scanning is recommended for advanced users as with the SSL communication redirected through the ESET's scanner, some applications communicating over SSL may fail to establish a connection if they don't trust the ESET's root certificate.

 

When there's a certificate problem in a browser or email client, try the following:

- with all browsers and email clients closed (check running processes in the task manager), disable SSL scanning in EAV/ESS and click ok

- re-enable SSL scanning

- launch the browser and see if it works now fine

 

In order to export the root certificate, navigate to SSL->Certificates in the EAV/ESS setup and click the "View certificate" button. A window with certificate details will show up, allowing you to export it to a file. The file can be subsequently imported to browsers.

Link to comment
Share on other sites

I have the same problem, I like to use Firefox for everything but SSL just is not working as the above issue says.

 

It is a known issue that isn't fixed by ESET: KB Solution ID: SOLN3126

 

Look also at this thread: HTTPS and Google

Edited by User
Link to comment
Share on other sites

  • Administrators

I'm not aware of any issues with Firefox and SSL scanning. The article is 1 year old and was created probably as a quick fix for certificate issues.

Does the problem persists if you do the following?

- with all browsers and email clients closed, disable SSL scanning

- rename the files C:\Users\%USER%\AppData\...\Mozilla\Firefox\Profiles\%PROFILE_NAME%\cert_override.txt and cert8.db

- start Firefox

- close Firefox (make sure it's not running by checking the task manager)

- enable SSL scanning

- start Firefox

 

Let me know if it resolves the issue or not.

Link to comment
Share on other sites

I tried this too and initally exactly the same, then I changed the search engine to yahoo and it works.

But when I went back to google same problem?

 

IT works now after I added an excemption to google.com but does that mean it no longer scans google.com?

Link to comment
Share on other sites

I am pretty sure BitDefender's SSL Certificate worked on all Browsers!

 

I searched the bitdefender forums and found this:

hxxp://forum.bitdefender.com/index.php?s=&showtopic=49441&view=findpost&p=201879

hxxp://forum.bitdefender.com/index.php?showtopic=47606&hl=

 

In the other thread @Marcos has a link to Kaspersky with the same problem.

So it seems to me now that other antivirus programs have the same problem with Firefox and SSL protection. (And some do not even have SSL protection at all live Avira or Avast).

 

So maybe Mozilla has to change something in their program?

Link to comment
Share on other sites

  • Administrators

The good news is that we've pinpointed the issue. It will be fixed in the Internet protection module 1092 which is going to be released to pre-release update servers some time soon.

Link to comment
Share on other sites

After you have enabled Pre-release updates then manually click on the update button and all available PR modules should be downloaded.

 

You don't "install" it like a program, the product handles the updates of new modules automatically, there's nothing you need to do.

 

Edit: By the way, the 9122p is the Virus Signature Database (VSD) that's not the module.

 

To check the modules right-click on your ESET icon the "e" in the systemtray and chose "About" then you will see a list of all the modules including the Internet Protection Module and there you will see the module numbers too.

Edited by SweX
Link to comment
Share on other sites

Thanks, I have the new module installed now.

 

It still does not Add the Certificate automatically like it does for IE and Chrome BUT after Importing manually it is now working.

Hope to see Automaic Adding of the Certificate working in the future so I don't have to muck around with the rest of the family PC's to get it working.

Thanks.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...