Jump to content

Archived

This topic is now archived and is closed to further replies.

wert

Problem with installation ERA Server on Debian 7.8.

Recommended Posts

I am having problem starting the installation of ERA Server on Debian 7.8.

I used this command-line :

sudo ./Server-Linux-x86_64.sh \
--skip-license \
--db-driver=myodbc_mysql \
--db-hostname=127.0.0.1 \
--db-port=3306 \
--db-admin-username=root \
--db-admin-password=password1 \
--server-root-password=eraadmin \
--db-user-username=era \
--db-user-password=password2 \
--cert-hostname="192.168.1.51;eset-era"

And output is:

ESET Remote Administrator Server Installer (version: 6.2.200.0), Copyright © 1992-2015 ESET, spol. s r.o. - All rights reserved.

Extracting archive, please wait...
Archive extracted to /tmp/tmp.g5h6DozmN6.
Checking OpenSSL ... done [OpenSSL 1.0.1e 11 Feb 2013]
Reading previous installation settings ... failure
Checking installed version... done
Status of current installation is: NEW
Loading GUID ... failure

Error: : Error occured while loading GUID

My log file:

2015-09-24 09:13:14 Information: Installer: Initializing logging to file /var/log/eset/RemoteAdministrator/EraServerInstaller.log
2015-09-24 09:13:14 Information: Installer: Parsing arguments.
2015-09-24 09:13:14 Information: Installer: Verifing arguments.
2015-09-24 09:13:14 Information: Installer: Starting install sequence.
2015-09-24 09:13:14 Information: Installer: Extracting archive to /tmp/tmp.g5h6DozmN6
2015-09-24 09:13:15 Information: Installer: Archive extracted to /tmp/tmp.g5h6DozmN6.
2015-09-24 09:13:15 Information: Installer: Checking OpenSSL ...
2015-09-24 09:13:15 Information: DepCheckOpenSSL: Action invoked with:
2015-09-24 09:13:15 Information: DepCheckOpenSSL: Set output property: P_OPENSSL_VERSION = OpenSSL 1.0.1e 11 Feb 2013
2015-09-24 09:13:15 Information: DepCheckOpenSSL: Return code: 0
2015-09-24 09:13:15 Information: Installer: Found: OpenSSL 1.0.1e 11 Feb 2013
2015-09-24 09:13:15 Information: Installer: Reading previous installation settings ...
2015-09-24 09:13:15 Information: LoadInstalledData: Action invoked with:  --db-connectors-dir /tmp/tmp.g5h6DozmN6/setup --db-driver myodbc_mysql --db-hostname 127.0.0.1 --db-name era_db --db-port 3306 --db-type MySQL Server --db-user-password ********** --db-user-username ********** --modules-dir /var/opt/eset/RemoteAdministrator/Server/Modules/ --product-guid "" --product-name Server --startup-config-path /etc/opt/eset/RemoteAdministrator/Server/StartupConfiguration.ini
2015-09-24 09:13:15 Error: LoadInstalledData: Startup configuration file '/etc/opt/eset/RemoteAdministrator/Server/StartupConfiguration.ini' does not exist, is empty or is not regular file
2015-09-24 09:13:15 Information: Installer: Failed reading previous installation settings.
2015-09-24 09:13:15 Information: Installer: Checking installed version...
2015-09-24 09:13:15 Information: CheckVersion: Action invoked with:  --current-version 6.2.200.0 --installed-version ""
2015-09-24 09:13:15 Information: Product is not installed
2015-09-24 09:13:15 Information: CheckVersion: Set output property: P_VERSION_STATUS = NEW
2015-09-24 09:13:15 Information: CheckVersion: Return code: 0
2015-09-24 09:13:15 Information: Installer: Checking of installed version was successful
2015-09-24 09:13:15 Information: Installer: Status of current installation is: NEW
2015-09-24 09:13:15 Information: Installer: Loading GUID ...
2015-09-24 09:13:15 Information: LoadCorrectProductGuid: Action invoked with:  --db-admin-password ********** --db-admin-username ********** --db-connectors-dir /tmp/tmp.g5h6DozmN6/setup --db-driver myodbc_mysql --db-hostname 127.0.0.1 --db-name era_db --db-port 3306 --db-type MySQL Server --db-user-password ********** --db-user-username ********** --product-guid "" --product-name Server
2015-09-24 09:13:15 Information: GetDatabaseServerConnectionStringWithoutEscape: Created connection string: 'Driver=myodbc_mysql;Server=127.0.0.1;Port=3306;User=******;Password={******};CharSet=utf8;'
2015-09-24 09:13:15 Information: Installer: Failed loading GUID.
2015-09-24 09:13:15 Information: Installer: Error: : Error occured while loading GUID

Why script can not genereate new GUID?

 

 

Share this post


Link to post
Share on other sites

Hello

 

I've also this issue.

 

This is caused by incompatible version of the mysql libraries. Version 6.2.200 of Proxy/Server requires mysql 5.5. 5.6 is not compatible. Downgrading to 5.5 resolves this issue.

 

I hope someone at Eset can see this topic in order to release a new version of Proxy/Server supporting 5.6.

Share this post


Link to post
Share on other sites

Hello,

Thank you for bringing this up. I will check with our developers.

 

EDIT: The version of MySQL was tested in our environment and it worked correctly. If you keep having the issue, please contact your local customer care and provide them with the log and additional information about the system.

Thanks.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...