Jump to content

ESMX v6.2 potentially causing SBS2008 to Freeze?


Recommended Posts

Hi,

 

I'm having problems with our SBS2008 since we installed Eset Mail Security for Exchange v6.2 (6.2.10009.0) last week, where the server repeatedly has become unresponsive and required a hard power off with the power button. (at least 4 times in the last week at random times on a previously very stable server)

 

I have been unable to find the culprit for the problems, so can't prove it is EMSX v6.2 that is at fault, although that is the main thing that has changed on the server recently. (The other being some Windows Updates which could also be the cause).

 

I would roll back to EMSX v4.5 to test stability on that version, except that I installed v6.2 because I was having problems with v4.5 where it had stopped scanning emails completely and was pouring spam and viruses through to my users untouched, which wasn't acceptable!

 

I've just increased the RAM today from 8GB to 16GB in case it was short of RAM.... but I very much doubt it, as we really aren't stretching this box (humming along saying it is using just 5.4GB of 16GB at the moment). When the system freezes it seems to be CPU bound not RAM bound.

 

The SBS2008 is running in a Hyper-V virtual machine.

 

I've seen this thread concerning a potential hotfix for Windows which might fix it, although it says this problem is sorted in ESWF, so I'd have assumed it was also fixed in EMSX v6.2 too, but this isn't necessarily true. Also the Eset KB mentions this applies to SBS2008, but the Microsoft Hotfix doesn't list SBS2008 as one of the supported systems.

 

Also concerning me is that this problem wasn't apparent on this server when I was running EMSX v4.5 even though that is supposedly one of the systems which would need the MS Hotfix.

 

Is there an easy way to prove from some logs (either Windows or Eset) or diagnostic routine whether this Microsoft hotfix will help me, or prove what application is causing the system to freeze (prove definitively whether it is ESMX or something else causing the problems). My users have faced too many reboots in the last week already (I gave the system three reboots trying to fix v4.5 last week, one reboot whilst installing v6.2 and four more to solve system freezes), so I am not keen to start changing system setup further unless I know it will help.

 

Thanks in advance for your help,

 

Mike

Link to post
Share on other sites

Because I was nervous about installing the Hotfix without proof that it:

a) works on SBS2008, and

b) was likely to help the problem anyway;

.... instead I've disabled the Protocol Scanning features for Web and Email in EMSXv6.2 (as I don't think they were enabled on the previous EMSXv4.5) and that was an alternative solution offered by Marcos in the other thread:

 

Alternatively you could disable protocol filtering to prevent the bug in Windows Filtering Platform from manifesting. Normally this shouldn't be a problem as servers shouldn't be used to browse websites or receive emails with the exception of terminal servers.

 

 

I'll have to wait now to check whether that has helped my server regain stability or not.

 

I am surprised though, as the Eset KB article suggests that the latest products shouldn't need to use this hotfix:

 

 

Important!Server Operating Systems: This issue has been resolved with the release of ESET File Security for Microsoft Windows Server (EFSW).

 

Yet here we are with EMSXv6.2 potentially suffering this problem, (although not yet confirmed!).

 

Would love to be sure we have this solved, and know that we have disabled the correct bits... and are therefore still secure and fully protected (I don't want to have reduced protection by mistake), but also stable again (my users don't want any more outages!!).

 

Thanks in advance for your help

 

Mike

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...