Jump to content

Cannot get package from repository

Recommended Posts

Dear Eset Team,


I have updated to ERA V6.2 today and also rolled out the new Agent Live installer.

This worked fine. Good improvements in this version.


Still there are bugs. I cannot get a package from the repository.

I can push an installation command from ERA6 to a client.

But it never gets installed. I got this from the detailed execution view




I have set the update server to "autoselect".

Im still in the process of getting in a lot of new clients with EEAv4 EEAv5 and i need to make sure they can update trough ERA to v6.



Can you help?



Link to comment
Share on other sites

  • Administrators

First of all, if you connect through a proxy server make sure it's set correctly in the Agent Live installer. You can also configure it later via an agent policy.

Unfortunately, the return error code is not visible in your screen shot, only "(error c..." is visible and the actual number is missing. Please get the agent trace log from the client and send it to me via a pm for analysis. Also a Wireshark pcap log from the time of agent installation might shed some light.

Link to comment
Share on other sites

 The error code is visible on the screenshot.

I have attached it again

we do not use a proxy, we want them to update from available era servers.

i know this can increase the bandwidth but this is not a problem for us.

we just want older clients to grab the newest installation file and install it.

that's what i am trying to push with task, which fails as described above


Link to comment
Share on other sites

Hi Marcos,


I have checked again the configuration and saw that one policy was pointing wrong to the address above.

i cleared that and tried again to deploy components upgrades for security products without luck.


I had to generate a new certificate while upgrading to 6.2.

How can i push the new certificate to the existing clients?


I think this may be the problem why they cant update them self when i push the installation task from ERA6 webconsole.

Virus signature updates are working fine, i just cant get th clients to update to the newest security product.

Link to comment
Share on other sites

Ok recreating the Live Installer worked that the client connects again to the era server again.

i can roll out policies, wake-up call, reboot etc.


The only thing not working is updating the antivirus itself. Signature database update works fine but every time i try to run a Software Install task, it points to av2.appway.com which is the DNS name of our ERA6 server.

but i have checked all policies. There is no policy or setting pointing to that address nor have i setup a HTTP proxy.

i just want them to update through the ESET repository.


Here are some screenshots from the settings:



Link to comment
Share on other sites

  • Administrators

When creating a software install task, did you select "Install package from repository" and not "Install by direct package url" ? Make sure that you're not sending an older software install task that might have pointed to av2.appway.com.

Link to comment
Share on other sites

  • Administrators

What about creating an agent policy that will have the repository set to the default value AUTOSELECT ? This should solve the problem with software install tasks.




As for the problem with updating Endpoint clients, please send me a complete error message that you're getting. If you have physical access to one of those computers, try running update manually and post here the recent records from the ESET event log.

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...