Jump to content

Scheduled tasks don't run when windows 10 is locked


Recommended Posts

I had previously started a topic in which I thought my problem was that scheduled tasks didn't run in windows 10, no matter what.

 

In the weeks since I've tried reinstalling windows 10 and eset smart security, with no luck, until today.

 

I have now discovered that if you are logged into windows 10, but the system is locked - as I leave my system overnight, scheduled tasks don't run.

 

I tested this by setting a scheduled task of an on-demand scan to start in a couple of minutes, then sitting here and watching the time tick by, then right on the minute, the scan started.

 

I then repeated this process, but after scheduling the scan, I locked the system (using winkey+L) - I then waited for the scheduled time to be reached, then waited several minutes before unlocking, when I expected to see the scan running - It wasn't running.

 

I've repeated this several times now, each with the same result.

 

 

Any ideas?

 

 

Many Thanks,

Christopher Gibbins

Link to comment
Share on other sites

  • ESET Moderators

Hello losimagic,

 

Can you please confirm whether this hapeens also when you open advanced settings (by pressing the F5 key), go to Computer > Gamer mode and uncheck "Enable Gamer mode when running applications in full-screen mode automatically"?

 

Gamer mode postpones all scheduled tasks in order to keep the computer's full performance available for full-screen apps, such as games. Maybe the lock screen in Windows 10 presents itself to the system as a full-screen app, which triggers this feature in our product.

 

Thank you.

Link to comment
Share on other sites

Hello losimagic,

 

Can you please confirm whether this hapeens also when you open advanced settings (by pressing the F5 key), go to Computer > Gamer mode and uncheck "Enable Gamer mode when running applications in full-screen mode automatically"?

 

Gamer mode postpones all scheduled tasks in order to keep the computer's full performance available for full-screen apps, such as games. Maybe the lock screen in Windows 10 presents itself to the system as a full-screen app, which triggers this feature in our product.

 

Thank you.

 

Thank you, that does appear to be the issue - I've tested it a fair bit this evening with 'example' scheduled tasks and have now set up my nightly ones.  Will report back if the issue is solved.

 

is there any way to exclude the lock screen from the game-mode detection?

Link to comment
Share on other sites

  • ESET Moderators

There are no options to exclude apps from the detection on user's side.

However, should you confirm that it really is caused by the Gamer mode, I will submit this to our developers as a bug in the product, so that they can fix it.

I will check this thread back to see your response.

Link to comment
Share on other sites

  • ESET Moderators

Thank you. I have tried the same scenario on my Windows 10 computer, but the tasks were started even with the setting turned on and with the OS locked (Win+L).

Nevertheless, I contacted our development team and asked them whether there is anything they want to investigate. I will get back to you once I hear from them.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...