Jump to content

PC with no connection to ERA server, not updating


jdaniel
 Share

Recommended Posts

Hello,

 

As the title says, we have PC's on remote sites, other cities etc. These PC's do not have access to the ERA server for extended periods of time. This can be weeks, months. Our company policy do not allow ports to be opened to outside.

 

Version 5 had no issues to download updates from the internet, connected or not to ERA server. In fact we did not even set up an update mirror. We always downloaded the updates from the internet. Version 6 refuses to update. If we connect the PC in the same network with the ERA server then it works, the client is updated.

 

Is this intended ? Or some configuration error in ERA on our side ?

Please advise.

 

Thanks.

Edited by jdaniel
Link to comment
Share on other sites

  • Administrators

Did you create dual update profiles, one for updates within your LAN and the other for computers outside the LAN? That way it worked in v5 and v6 works in the same way. 

 

Creation of dual update profiles:

v5: hxxp://support.eset.com/kb3036/

v6: hxxp://support.eset.com/kb3621/

Link to comment
Share on other sites

Hello,

 

Thanks for the answer. We did not modify anything in the updates configuration. As I said, we always downloaded them from the ESET servers. This worked in v5 without any configuration.

Do we need dual profiles in v6 if we only use the ESET servers ?

 

Looking at the kb for v6 you provided the only difference I see between our config and the one from the example is in Settings -> Update -> HTTP Proxy -> Proxy mode. In our config is selected "Use global proxy server settings" and in the example it's "Do not use proxy server".  Also I check in our Settings -> Update -> Basic -> Update server and it is set to "automatically".

 

Thank you.

Link to comment
Share on other sites

  • Administrators

If you update only from ESET's servers and do not use a proxy server in your LAN then you don't need to set up dual update profiles of course. Please create a Wireshark log from an attempt to update that fails. When done, compress it and supply it to me via a personal message.

Link to comment
Share on other sites

  • 3 weeks later...
  • 3 weeks later...

Hi,

Any updates on this one? We are having the same issue described here.

No updates for clients when clients are not connected to the ERA server.

In 5.x this was working fine, all updates were automatically downloaded from the internet instead of the ERA server.

 

Thanks in advance,

Roland

Link to comment
Share on other sites

  • 2 weeks later...
  • ESET Moderators

Hello jdaniel, have you been able to solve the issue by contacting Marcos?

 

rolandd - in case you figured it out, what was the solution? Other users may benefit from it too.

Link to comment
Share on other sites

  • ESET Moderators

I am sorry, many times the logs are forwarded to a different team, who will analyze them, fix an issue for an upcoming version, but won't have a workaround for those currently experiencing it.

However, you can always PM rolandd and ask what the solution was in their case.

Link to comment
Share on other sites

Hello,

 

Thank you again for replying to this thread. Can you please confirm that this is the case for our problem ? And if this is the case, when can we expect the fixed release ? Weeks, months, next year ?

 

You see, the problem is this thread and I dare to say in this forum is the lack of information, discussion. How hard is it to write a reply like "we found the issue, it will be fixed in the next release" or "this is your(read client/end user) fault, fix the settings in config/x/y/z" or "we received the logs, the analyze will take X months, we will get back to you". I do not want the response in 2 seconds but 6 weeks and no reply ? Seriously ?

 

I really want to use the new product but until it does not work, I can't and I won't. I will not uninstall a product that works in the entire company to install a product that does not.

 

Thank you again.

Link to comment
Share on other sites

  • 2 weeks later...

Nevermind, i figured it out

 

 

Did you create dual update profiles, one for updates within your LAN and the other for computers outside the LAN? That way it worked in v5 and v6 works in the same way. 

 

Creation of dual update profiles:

v5: hxxp://support.eset.com/kb3036/

v6: hxxp://support.eset.com/kb3621/

 

Was this your solution?

 

I had the same issue.  When on the company network, the ERA server was available and the updates occurred normally, but when I was hotspot tethered to my phone, the updates failed with an error "server not found".

I created the dual update profile as described in the link for ERA v6 and left the "Internet Update (no-proxy)" as the default profile instead of "My Profile"

I set the scheduler "automatic updates" as "My Profile" first and "Internet Update (no-proxy)" second.

 

I can confirm that a manual update will use the selected profile "Internet Update (no-proxy)" regardless of the network connected to it.  I have not checked to see if the server is being used first for automatic updates, but I plan to monitor that.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...