marble

"ESET requires your attention..." warning when using Microsoft Edge

Recommended Posts

Hi,

The attached image shows a strange bug caused by ESET Smart Security (8.0.319.1) on Windows 10 x64. When I'm using Microsoft Edge and there are several tabs open and I drag a tab from the top bar to the left to move it near another tab this exact warning shows up. Nothing else happens when I click on the warning. The bug reappears every time I move a tab to another position, which is very odd.

Can someone reproduce and confirm this bug?

post-8296-0-45665900-1439198654_thumb.jpg

Edited by marble

Share this post


Link to post
Share on other sites

I have more information regarding this bug:

ESET seems to launch the Gamer Mode when dragging a tab for several seconds, altough Microsoft Edge doesn't support full screen mode. That is also why this notification pops up.

Share this post


Link to post
Share on other sites

I can't seem to reproduce the issue and Gamer mode never gets activated when moving tabs in MS Edge.

Share this post


Link to post
Share on other sites

Indeed, the same notification keeps springing up on my computer as well. But when I click on it, there is no real notification, no need for updates, nothing. I am using Windows 10 home (x64-based processor), Google Chrome, Thunderbird. However, I haven't figured out what triggers this message. Can someone at eset nod32 please fix this bug? Thanks

Share this post


Link to post
Share on other sites

Indeed, the same notification keeps springing up on my computer as well. But when I click on it, there is no real notification, no need for updates, nothing. I am using Windows 10 home (x64-based processor), Google Chrome, Thunderbird. However, I haven't figured out what triggers this message. Can someone at eset nod32 please fix this bug? Thanks

Exactly the same.

I've tried this possible solution provided by ESET, but it didn't work for me.

Share this post


Link to post
Share on other sites

Exactly the same.

I've tried this possible solution provided by ESET, but it didn't work for me.

This KB is irrelevant. In that scenario, the notification was caused by an unknown / undocumented code returned by Windows which used to happen under different circumstances.

What you can do for now is to disable automatic activation of gamer mode when an application running in full-screen mode is detected.

Share this post


Link to post
Share on other sites

What you can do for now is to disable automatic activation of gamer mode when an application running in full-screen mode is detected.

 

Ha! It worked. Thanks, Marcos.

Share this post


Link to post
Share on other sites
Ha! It worked. Thanks, Marcos.

 

Unfortunately this is not a very good solution, as now everytime you start a full screen application (e.g. a game) you would have to manually activate the gamer mode.

Share this post


Link to post
Share on other sites

Personally I don't use gamer mode as I don't like postponing updates and want to keep ESET as up to date as much as possible. Should pop-up windows distract me while playing games, there's an option to disable them.

 

Of course, we'll have a look at this issue causing inconvenience to the users to find out if it can be fixed or worked around if Edge actually triggers a full-screen mode.

Share this post


Link to post
Share on other sites

I'm getting the same pop-up since I upgraded to windows 10. It happens a lot when I switch between windows using alt-tab. I have confirmed that it pops up when ESET switches to gamer mode. I don't use Edge so it is either not related to Edge or Edge doesn't need to be open for it to occur. I see it when I switch between LibreOffice Calc windows or Chrome windows. Those applications are what I use the most and haven't had time to test it with other apps.

 

Turning off "Setup->Enter Advanced Setup->Computer->Gamer mode->Enable Gamer mode when running applications in full-screen automatically" does get rid of the warning. However, this is merely a workaround.

 

There is an advanced setting "User interface->Alerts and notifications->Desktop notifications->Do not display notifications when running applications in full-screen mode". If this setting is checked (as it is in my config) these notifications should not pop-up.

 

It is clear from the appearance of this pop-up that it is not generated the same way that other notifications are generated (see sample notification attached) so it may not be governed by this setting. It appears that it is generated by the OS based on information the software is sending to it.

 

In this case the application should be changed so that the message is either not generated as frequently, is otherwise hideable, or is governed by this setting.

post-8746-0-06530000-1441863138_thumb.png

Share this post


Link to post
Share on other sites

Of course, we'll have a look at this issue causing inconvenience to the users to find out if it can be fixed or worked around if Edge actually triggers a full-screen mode.

 

It has nothing to do with the Edge itself. Full screen mode in Windows 10 that triggers ESET Gamer mode, turns on every time the user is switching between apps using Alt-Tab, Win-Tab, clicking on Task View icon on the Task bar etc. I assume dragging the tabs in Edge might be an action of the similar nature.

 

I believe the reason for this pop-up to appear all the time is due to changes to anti-virus software monitoring approach in Windows 10 compared to previous versions of Windows (at least, Win 7). One of the features of ESET Gamer mode (I suspect the postponing of virus signature updates) is recognized by Windows 10 anti-virus software monitoring as a potential problem. As a result, you get the notification about the problem. But when you click on that notification, Windows 10 turns off Full screen mode, ESET turns off Gamer mode, and you don’t see anything in response to your click/tap since the problem eliminates by itself.

 

For now, the workaround is to disable anti-virus software monitoring by Windows 10. But of course it’s not a solution, since Windows monitoring happens to be an additional level of protection and is very useful sometimes.

 

My understanding is that ESET developers should change the “anti-virus software status” for the Gamer mode that is provided to Windows 10 that way so Windows won’t think there’s something wrong with anti-virus. It is obvious that Microsoft won’t fix that since OS actions are relatively correct.

Share this post


Link to post
Share on other sites

I will bring back this post to say it really anoying and still not fixed
it can be reproduced also on google chrome with youtube 
leaving the full screen mod of youtube and this message popup

Share this post


Link to post
Share on other sites

I still have this problem when i alt+tab , any other fixes aviabile ? :(

Share this post


Link to post
Share on other sites

I have this problem as well.  When I use the alt+tab combo to switch between programs, I get this popup and a chime.  Very annoying and distracting.  Can someone please find a fix?

Capture.PNG

Share this post


Link to post
Share on other sites

Switch to pre-release updates in the advanced update setup so that you receive a new v10.1.219 among the first soon.

Share this post


Link to post
Share on other sites
1 hour ago, Marcos said:

Switch to pre-release updates in the advanced update setup so that you receive a new v10.1.219 among the first soon.

Are we talking about the same program?  I've got ESET Endpoint Antivirus, Version 6.5.2094.0.   

Share this post


Link to post
Share on other sites

I'm having the same issue with version 10.1.219.0. Every time I tab out from a game, I get a notification as described in this thread. This is getting quite annoying. I am aware that disabling gamer mode might be a workaround, but I'd prefer not having to disable features I pay for. Any fix on the way?

 

post-6-0-47700200-1439227270.png

Share this post


Link to post
Share on other sites

Getting the same annoying message over and over again. Not related to edge but every time I open VLC, or switch back to a browser. Started about a week ago or so. First thought it's related to my license running out soon. Almost the most annoying is, that it's just playing an annoying windows sound, gives this notification, tells you that you should click on it, and on doing so absolutely nothing happens.

Now switching to testing mode. But these pop-up messages were one of the reasons I moved away from kaspersky (they even kicked you out of running games to show you that you should purchase a new license soon).

Share this post


Link to post
Share on other sites

Does disabling the option to enable gamer mode automatically when an application running in full-screen mode is detected in the advanced setup -> tools -> gamer mode make a difference? Does disabling / enabling this option has any effect on performance when playing games or watching video?

Share this post


Link to post
Share on other sites

You can also try to set the Minimum verbosity of events to display to Warnings instead of Informative.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.