Jump to content

SSL Scanning Problem With Sandboxie


Recommended Posts

I'm running Windows 8.1 x64, ESET Smart Security 8 and Comodo Firewall. I'm using both Chrome and Firefox. ESS has Firewall and HIPS disabled.

 

The problem I'm having is when I have SSL Scanning enabled pages won't load when the browsers are run under Sandboxie, but outside Sandboxie they load fine. If I turn SSL Scanning off then pages load fine under Sandboxie.

 

I've tried giving Sandboxie all the powers I can give it but it doesn't help. I've read over on the Avira boards people had a similar issue, which Avira eventually fixed.

 

Does anyone know what's up? :wacko:

Link to comment
Share on other sites

Does the browser show SSL/TLS error messages? If so you maybe have to manually import the root certificate from ESS into these browsers.

Link to comment
Share on other sites

Does the browser show SSL/TLS error messages? If so you maybe have to manually import the root certificate from ESS into these browsers.

 
I attatched screenshots of the errors.
 
I've tried manually importing the certificate but it doesn't help. I've also tried unticking "Add root certificate to known browsers" and toggling SSL off an on again, then manually importing a fresh copy, no difference.
 
When the browser is open in Sandboxie I can see the certificate is there anyway, deleting and importing it again doesn't help.
 
Firefox:
 
Chrome:
Link to comment
Share on other sites

  • ESET Staff

@Ellie: What settings have you changed in ESS or Sandboxie? I'd like to ask you to start Firefox from Sandboxie, start Task Manager, click More details at the bottom left, then switch to Details tab on the top of the window and see what User name is next to the firefox process.

Link to comment
Share on other sites

@Ellie: What settings have you changed in ESS or Sandboxie? I'd like to ask you to start Firefox from Sandboxie, start Task Manager, click More details at the bottom left, then switch to Details tab on the top of the window and see what User name is next to the firefox process.

 

It says "ANONYMOUS LOGON".

 

I'm currently using a fresh Windows 8.1 x64, ESS and Sandboxie, no Comodo. The only settings I've changed is enabling SSL Scanning, changed nothing in Sandboxie.

Link to comment
Share on other sites

  • 2 weeks later...
  • ESET Staff

Try going to Advanced setup, Web and email -> Protocol filtering -> SSL -> Certificates and look for End certificate validity. Switch both options to Ask. Does that make any difference?

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...