Jump to content

Error during create database phase while installing server


Recommended Posts

During the install of Remote Administrator 6.0 setup fails during the database creation. The msi installer log reports the following after enabling verbose logging:

 

MSI (s) (7C!A0) [16:30:10:422]: Creating MSIHANDLE (840) of type 790531 for thread 17312
ERROR: (DbCreate) Statement execution failed. Error: Conversion of varchar-datatype to datetime-datatype resulted in an out-of-range value. File: C:\ProgramData\ESET\RemoteAdministrator\Server\SetupData\Database\SQLServer\CreateScripts\4_init_data.sql. Statement: INSERT INTO tbl_security_users (user_id, user_uuid, user_login, user_comment, password_change_timestamp, change_password_on_next_logon, password_expiration_interval_in_days, auto_logout_time_in_minutes, user_full_name, user_email, user_phone, user_state, disabled, native, removed, user_password_hash, user_password_salt) VALUES
 (5, dbo.ufn_uuid_str_to_binary('00000000-0000-0000-7002-000000000001'), 'system', '', '2012-01-26 12:00:00', 0, 1500, 10, 'System user', '', '', 0x, 0, 1, 0, 0x20, 0x20),
 (6, dbo.ufn_uuid_str_to_binary('00000000-0000-0000-7002-000000000002'), 'Administrator', '', '2011-10-12 12:00:00', 0, 1500, 10, 'Administrator', '', '', 0x, 0, 1, 0, );

MSI (s) (7C!A0) [16:30:10:422]: Closing MSIHANDLE (840) of type 790531 for thread 17312

 

Our SQL server is set to Dutch language settings. It appears that the script tries to insert a date in the US format while the server expects Dutch format.

 

Any idea on how to solve this?

 

Franc.

Link to post
Share on other sites

It's not the language of the SQL server installation, but the default language of the SQL server login used to create the database during setup. We have an English SQL server installation, but 'sa' has a default language of Dutch. Then ERA setup fails....

 

Any idea when the upcoming release will be available?

Edited by FrancWest
Link to post
Share on other sites
  • Former ESET Employees

New version should be available in couple of weeks.

 

Until then there is a temporary workaround:
Set default language to English for the database root login and era login as well (both are provided to ERA server setup).
Please note that it is not satisfactory to set the language to only one of the mentioned logins. Both must be set! The root login only for the time of ERA setup. ERA login language must remain permanent.
Also note that changing the default language for a DB login may influence other applications (if they share the same login).
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...