Jump to content

Problem installing ERA Server on fresh Ubuntu Server 14.04 x64


Go to solution Solved by mclusky,

Recommended Posts

This is my firs post here and firs ERA server issue.
About 2 weeks ago I installed my first ERA server under Ubuntu 14.04 x64 server - installation went rather smoothly.
Yesterday I started next installation on fresh Ubuntu 14.04 x64 server, with same steps - but I am unable to complete due to database connection issue.
Here are installation steps so far:
1) installation of mysql-server, setting max_allowed_packet=33M in /etc/mysql/my.cnf
2) installation of xvfb cifs-utils unixodbc libmyodbc
3) set /etc/odbcinst.ini as follows:

        [MySQL]
            Description = ODBC for MySQL
            Driver = /usr/lib/x86_64-linux-gnu/odbc/libmyodbc.so
            Setup = /usr/lib/x86_64-linux-gnu/odbc/libodbcmyS.so
            FileUsage = 1

4) create database and user for ERA Server (era_db and era_user respectively) - this was new step comparing to previous installation
5) issue installer command:

sudo ./Server-Linux-x86_64.sh \
--skip-license \
--db-driver='MySQL' \
--db-hostname=127.0.0.1 \
--db-port=3306 \
--db-admin-username=root \
--db-admin-password=[my_pass] \
--server-root-password=[my_pass] \
--db-type='MySQL Server' \
--db-name=era_db \
--db-user-username=era_user \
--db-user-password=[my_pass] \
--cert-hostname="192.168.1.240;Server2"

The installer output:

Extracting archive, please wait...
Archive extracted to /tmp/tmp.lU6NAuLl0Y.
Checking OpenSSL ... done [OpenSSL 1.0.1f 6 Jan 2014]
Checking installed version... done
Status of current installation is: NEW
Generating GUID ... done [GUID = 8b0e10fa-7608-4b0a-824d-680da691610b]
Checking database connection ... failure
Error: Admin connection not working. Unable to continue.

The most important part of /var/log/eset/RemoteAdministrator/EraServerInstaller.log file:

2015-04-10 09:23:03 Information: Installer: Checking database connection ...
2015-04-10 09:23:03 Information: DbCheckConnection: Action invoked with:  --db-admin-password ********** --db-admin-username admin --db-connectors-dir /tmp/tmp.lU6NAuLl0Y/setup --db-driver MySQL --db-hostname localhost --db-name era_db --db-port 3306 --db-type MySQL Server --db-user-password ********** --db-user-username era_user --silent-reinstall ""
2015-04-10 09:23:03 Information: DbCheckConnection: Set output property: P_DB_PORT = 3306
2015-04-10 09:23:03 Information: GetDatabaseServerConnectionStringWithoutEscape: Created connection string: 'Driver=MySQL;Server=localhost;Port=3306;User=admin;Password={******};CharSet=utf8;'
2015-04-10 09:23:03 Information: Entering function: void Era::Setup::Common::CustomActions::CDatabaseReader::TryUserConnectionForDBServer(const string&, const string&, const string&)
2015-04-10 09:23:03 Information: Entering function: void Era::Setup::Common::CustomActions::CDatabaseReader::TestConnection(const string&, bool)
2015-04-10 09:23:03 Information: DbCheckConnection: Set output property: P_DB_ADMIN_CONNECTION_STATUS = 0
2015-04-10 09:23:03 Information: ERROR: DatabaseException with error code '0' and message - [unixODBC][Driver Manager]Data source name not found, and no default driver specified
2015-04-10 09:23:03 Information: DbCheckConnection: Return code: 0
2015-04-10 09:23:03 Information: Installer: Admin connection check failed. Unable to continue.
2015-04-10 09:23:03 Information: Installer: Error: Admin connection not working. Unable to continue.

I need to mention that I am able to log with root account (and password passed to installer) to mysql console. I tried also:

- changing password for mysql root account and creating new administrator account

- using mysql root and password account in installer options --db-user-username and --db-user-password options

- using 'localhost' and machine name in installer option --db-hostname

but it doesn't solve problem.

 

mclusky
 

Link to post
Share on other sites
  • Solution

I have found the reason for this issue. It was ODBC definition in /etc/odbcinst.ini. There shouldn't be any leading spaces/tabs before Driver and Setup statements - file content should look like this:

[MySQL]
Description = ODBC for MySQL
Driver = /usr/lib/x86_64-linux-gnu/odbc/libmyodbc.so
Setup = /usr/lib/x86_64-linux-gnu/odbc/libodbcmyS.so
FileUsage = 1
Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...