Jump to content

how to configure clients so that they will get updates from HTTP proxy internally and directly when they are outside the company network ?


verus
 Share

Recommended Posts

Hi,

 

I configured the settings so that the clients get their updates via the HTTP proxy server but a lot of our users work also outside or from home.

So I want that ESET updates directly from internet when the internal network with the HTTP proxy server is unavailable.

How can I do that ?

thanks, Philippe.

Link to comment
Share on other sites

Here is my 2 cents regarding this,maybe I am wrong. 

First you need to go to Update section of Policy ESET Security Product for Windows, in there in general in List in profiles, below the My profile, go to edit and create new profile (Internet update for example). Then choose Internet update profile, in the settings for that profile below, go to http proxy part and change the Use global proxy to Do not use proxy server. When that is done, you can swith back to My profile as the default one. 

Then go to tools/scheduler, choose Regular automatic update, and click next until you get to the part where you have primary and secondary profile. Untick use default for both, and on the first one,you can leave My profile,but for the secondary change it to Internet update profile. 

I think these are all the steps, not really sure.. This is only logical thing for me for this to work. 

 

Maybe someone from ESET can give their opinion?

Link to comment
Share on other sites

  • Administrators

Maybe someone from ESET can give their opinion?

That's exactly how the process is described in the KB article for older versions and it works with v6 the very same way except that the policy is not edited via a stand-alone configuration editor.
Link to comment
Share on other sites

Hi,

Thanks for the feedback.

I configured it as you say and I will test it this evening with my computer.

 

One more question about the "USE PROXY SERVER" in the TOOLS section.

Is the "use proxy server" in the tools section used when the UPDATE section proxy mode is set as USE GLOBAL PROXY SERVER SETTINGS or else why is there a proxy setting in tools if there is already a proxy setting in update ?

 

thanks,

Ph.

Link to comment
Share on other sites

When you choose to work with these profiles, the APPLY setting is automatically set and when you remove it, the profiles are also removed.

When the apply is set, then it is not possible anymore on the client to overrule the setting, there is a lock icon.

This seems unlogical, it should be possible to overrule this on the client if I want to do that.

 

Also, when you edit the profiles and you remove the "My profile" (I don't like the name), then all other profiles are also removed and when you only have the "my profile" and you remove it and you add another one like test (or whatever), then you get an error:

 

Failed to get values, path plugins.01000400.profile.profile.1.settings

 

That's buggy behavior...

Edited by verus
Link to comment
Share on other sites

  • Administrators

One more question about the "USE PROXY SERVER" in the TOOLS section.

Is the "use proxy server" in the tools section used when the UPDATE section proxy mode is set as USE GLOBAL PROXY SERVER SETTINGS or else why is there a proxy setting in tools if there is already a proxy setting in update ?

 

That's correct. You can use a different proxy server for updates. If you want to use the same proxy for the whole program, you'd select to use global proxy settings in the updater and configure it under Tools -> Proxy server.

Link to comment
Share on other sites

thanks, about the APPLY setting and the profiles, that is not logical that as soon as you work with multiple profiles the settings are applied and can't be overruled by an admin on the client itself.

Is that a bug or still incomplete because that would be desirable.

Link to comment
Share on other sites

I try to update outside the network with the configuration settings as explained and I get a connection error message.

Is there a log where I can find information about this ?

post-6083-0-48930100-1426533859_thumb.png

Link to comment
Share on other sites

Hi,

 

This is still not working for me and it is configured as explained in this topic so there is no fault in the configuration.

screenshots of my configuration are attached (I placed a follow up number like (1) (2) (3) etc...  in the pics because the uploader mixes the order)

Is there anyone who configured this and has this working ?

Setting up different profiles for users so that they can choose another profile doesn't work too because as soon as you make a new profile it is APPLIED and the users can't choose another one but I will make another post for that.

 

@ ESET, please support on this specific topic since it is NOT working as it should.

 

Philippe.

 

 

 

 

post-6083-0-36602600-1426753764_thumb.png

post-6083-0-53143400-1426753770_thumb.png

post-6083-0-77023900-1426753774_thumb.png

post-6083-0-29687500-1426753779_thumb.png

post-6083-0-10640700-1426753784_thumb.png

post-6083-0-23598400-1426753788_thumb.png

post-6083-0-08860600-1426753793_thumb.png

post-6083-0-42785100-1426753799_thumb.png

post-6083-0-59708800-1426753805_thumb.png

post-6083-0-11444900-1426753811_thumb.png

post-6083-0-83183500-1426753815_thumb.png

Link to comment
Share on other sites

Hi Verus, 

 

As i can see here, in the My profile part, maybe put use global proxy settings.

In this topic you can see reply from ESET regarding proxy, http proxy, http proxy settings in Update part of Antivirus policy. 

 

https://forum.eset.com/topic/4316-apache-http-proxy-and-updates-from-cache-server-several-questions/

 

For My Profile settings in http proxy part, my configuration is as in picture below:

 

post-6646-0-95506100-1426756881_thumb.jpg

 

And global settings for HTTP proxy server i made in Tools/Proxy server in the same policy(antivirus one)

 

I too had couldn't connect to server last night, but then, i clicked update manually, and it did check for updates..Will check again over the weekend if this works as it shoud :)

Edited by ucvijan
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...