Jump to content

administrator agent service version 6.1.365.0 crashes after update from version [SOLVED]

Recommended Posts



A few days ago I updated our ESET server according the following procedure hxxp://kb.eset.com/esetkb/index?page=content&id=SOLN3668&locale=en_US

After the update, the administrator agent service on the clients crashed after a reboot or after a manual service restart.

Hereby the status log after the installation: status_log_first_install.png

And also the log after a reboot or service restart: status_log_administrator_agent_service_restart.png


After a reboot the service doesn't start anymore and a message in the windows event log is generated.

It's a message without any useful information (%%70 error).


I don't find a lot of information in the trace.log after the first installation and the trace.log after a reboot or manual restart of the service (which fails) doesn't give me any newsbreaking facts also.


When I install admin agent version, everything works fine.

The agents were upgraded to the latest version and in that task, the correct certificate was chosen so I had no idea why this fails and I thought it was the new agent since it works with the old agent.


The clients have some policies and one of those policies is that the agent on the administrator agent client checks every x minutes with the server.

If you check those settings, there is a "connection" section and in that connection section, there is a CERTIFICATE setting and that setting was empty.

When I edit that setting and I select the current certificate and I redeploy the agent to that computer, everything works fine and I have no more errors and service starts up as it should.

Strange since that worked perfectly with the previous version.


Maybe someone else is also helped with this explanation.






Edited by verus
Link to comment
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...