Jump to content

Archived

This topic is now archived and is closed to further replies.

invisik

Install error.... "1"

Recommended Posts

Hi..

 

Trying to install latest 5.x ESET Endpoint on a Windows 7 Pro SP1 64-bit machine.  I'm running the Smart Installer like I've done on many other machines before.  I'm installing under a administrative-equivalent domain user account--I've even specifically added it as a local user with Administrator privileges.  I've had it redownloaded the executable too. Previously the machine had AVG CloudCare, I uninstalled it and then ran the AVG Remover.  Have rebooted the computer twice since that.

 

The message I get is simply "1".  (See attached)

 

Any suggestions on how to get this installed?

 

Thanks!

 

-m

 

PS:  MSE did install fine.  Machine appears to not be infected as MSE and Malwarebytes come up clean.  I also logged in under the actual domain Administrator account and tried installing with the same error.

post-6511-0-30854700-1425886251_thumb.jpg

Share this post


Link to post
Share on other sites

Not sure what you mean by "smart installer" as Endpoint uses standard msi packages for installation unlike home version which is distributed via Live installers that download the appropriate msi.

I reckon the message appears if you push an installer to a computer and a competitive antivirus is detected.

Share this post


Link to post
Share on other sites

I am on the MSP program (managed service provider).  On my end, the ESET system generates SmartInstallers for each applications (ESET Endpoint, File Server, etc).  When it's run, it downloads and accompanying MSI file and runs it, just as you describe.

 

This system had TrendMicro on it prior to AVG, maybe there is a remnant of that.  I'll check on it.  Thanks.

 

-m

Share this post


Link to post
Share on other sites

You can run the install with MSI switch "INSTALL_CONFLICTS=1" (remove quotes) which will bypass the conflict check and continue the silent installation if you are sure there are no remnants that may cause confliction. The "1" denotes a conflict.

Share this post


Link to post
Share on other sites

Ahh cool, will give that a try.  Thanks much for the tip!

 

-m

Share this post


Link to post
Share on other sites

We have the same error "1" on many clients and we are also ESET MSP and use the Smart Installer MSP Utilities create. How do we add the switch to the MSI installer that are in the .exe file?

 

SmartInstaller,xxx.xxx.com,ESET Endpoint Antivirus,EEA,DEFAULT,xxx,xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx.exe

Share this post


Link to post
Share on other sites

I reckon that it is displayed when another av product is detected and the installer is run in quiet mode. Are you positive that no other av product is installed?

Share this post


Link to post
Share on other sites

We are 100% sure that the system is clean from other AV products. Many of our customers have been using BitDefender and when we uninstall it we always get error "1" from ESET. We found the thing ESET don't like and it's such a small thing.. a empty registry group that we need to remove

 

HKEY_LOCAL_MACHINE\SOFTWARE\BitDefender

 

Removed and ESET installs fine. So is there any way to include the switch INSTALL_CONFLICTS=1 in MSP installer?

Share this post


Link to post
Share on other sites

I noticed today that if I look in the log file generated by the Smart Installer, right near the end of it is the command line it is using to install the MSI package.

 

sample command line:

 

C:\WINDOWS\system32\cmd.exe /C MSIEXEC /I "C:\dl\eea_nt32_enu.msi" ADMINCFG="C:\dl\OFFICE01-PC.domain.local.107.2044\resources\DeployConfiguration.107.xml" /qb!

 

You can cut and paste this to a command prompt and it will run.  I ran it today without the /qb! on a machine that the installer was just exiting with not much other info.  It installed manually fine, although I don't think it took the ADMINCFG file, it was easy enough to manually add my update server and after it communicated it got the proper policy, so it's working normally now.

 

Ok.... and to my point... :)  Maybe the IGNORE_CONFLICTS switch can be used on this command line?  Please post back if you try it.....

 

Thanks.

 

-m

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...