Jump to content

[Help / Advice] Error while installing Agent V6 on Linux based ERA 6 server


Go to solution Solved by michalp,

Recommended Posts

Hi all,

 

We are actually deploying the ERA 6 server on our Linux Debian 7.8 server to manage our licenses but we do have some troubles.

 

The ERA server and Web console have been installed succesfully. By that we mean that installation has ended without any problem and that we can use the web console (and generate the needed certificates).

But next step is to setup an agent on the server itself (as it seems to be needed), and that's were we actually do have problems.

 

From web console we donwloaded the "Agent Certificate" and the "Certificate Authority Public Key" that were generated at server installation (those that are allready listed).

Then we just run following Agent-Setup command specifying the agent certificate and CA public Key:

./Agent-Linux-x86_64.sh \
--skip-license \
--cert-path="/PATH/Certificate Export CN=Agent at _ C=US.pfx" \
--cert-auth-path="/PATH/Certification Authority CN=Server Certification Authority C=US public key.der" \
--cert-password= \
--hostname=SERVERIP \
--port=2222

Note, the pre-generated Agent Cert has no password, therefore we leave the password field blank.

 

But the installation fails with following error:

Database status is 'DB_INVALID'. Database cannot be upgraded, because it is corrupted or it is not ERA database.

Searching through log file, those are the last lines:

2015-03-04 10:37:23 Information: Installer: Reading database status...
2015-03-04 10:37:23 Information: DbCheckStatus: Action invoked with:  --cert-auth-content "" --cert-auth-path /PATH/Certification Authority CN=Server Certification Authority C=US public key.der --cert-auth-temp-path "" --cert-content "" --cert-password ********** --cert-path /PATH/Certificate Export CN=Agent at _ C=US.pfx --cert-temp-path "" --cert-to-check-password ********** --cert-to-check-path /PATH/Certificate Export CN=Agent at _ C=US.pfx --computer-added-uuid "" --computer-group-choice DEFAULT --connection-chosen host --current-version 6.1.450.0 --db-connectors-dir /opt/eset/RemoteAdministrator/Agent/setup --db-path /var/opt/eset/RemoteAdministrator/Agent/data.db --db-scripts-dir /opt/eset/RemoteAdministrator/Agent/setup/Database --db-type SQLite --db-upgrade "" --era-lib-dir /opt/eset/RemoteAdministrator/Agent/ --hostname SERVERIP --installed-version 6.1.450.0 --log-sequence-id "" --modules-dir /var/opt/eset/RemoteAdministrator/Agent/Modules/ --port 2222 --product-guid GUID --product-name Agent --replication-interval "" --server-cert-temp-path "" --webconsole-hostname "" --webconsole-password ********** --webconsole-port 2223 --webconsole-user Administrator
2015-03-04 10:37:23 Information: Entering function: std::string Era::Setup::Common::CustomActions::CDatabaseReader::GetDatabaseStatusForEmbeddedDB(const string&, const string&, const string&)
2015-03-04 10:37:23 Information: Entering function: std::string Era::Setup::Common::CustomActions::CDatabaseReader::GetDatabaseStatus(const string&, const string&, const string&, std::stringstream&, std::vector<std::basic_string<char> >&)
2015-03-04 10:37:23 Information: DbCheckStatus: Set output property: P_DB_STATUS = DB_INVALID
2015-03-04 10:37:23 Information: DbCheckStatus: Return code: 0
2015-03-04 10:37:23 Information: Installer: Parsed output property: arg_db_status=DB_INVALID
2015-03-04 10:37:23 Information: Installer: Database read successfully.
2015-03-04 10:37:23 Information: Installer: Database status is 'DB_INVALID'
2015-03-04 10:37:23 Information: Installer: Database status is 'DB_INVALID'. Database cannot be upgraded, because it is corrupted or it is not ERA database.

As we can see there seems to be a problem with the database... But which one ?

Regarding following line in the logs, we assume that the Agent has its own database (an sqlite one):

--db-type SQLite

But we have no idea on what to do to debug this situation...

 

 

 

 

If someone has any idea or steps to find out what is wrong here, we would be very pleased.

 

Best regards,

G.

Edited by Adhara-CS
Link to post
Share on other sites

Hi,

 

We just checked if the sqlite database of the Agent really exists:

And it exists at:

/var/opt/eset/RemoteAdministrator/Agent/data.db

But we have no idea about how to check the:

it is corrupted or it is not ERA database

Best regards,

Link to post
Share on other sites
  • ESET Staff
  • Solution

Some previous failed Agent installation caused this. Please run 

./Agent-Linux-x86_64.sh --uninstall

 that should clean up any old files. Then run installer again. If there is no password for agent certificate (.pfx), then --cert-password= parameter is not necessary.

Link to post
Share on other sites

Hi michalp..

 

Indeed, that was the problem ! The previous unsuccessfull installation may be the root cause.

May be it should be added in the Agent installation documentation errors documentation.

 

 

Thank you very much !

Edited by Adhara-CS
Link to post
Share on other sites
  • 1 year later...

Hi, my problem is similar of this, but the error is :  Error '2' occurred while reading database: Current locale settings are invalid. And I tried to uninstall the agent and reinstall but still gives me the same problem. At the time of the installation of ERA server in the parameter --locale =  I change for es-ES. Thx

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...