Jump to content

ERA 6, Upgrade OVA to latest version?


Go to solution Solved by merickson,

Recommended Posts

Hello all,

 

Any idea how to upgrade the OVA to the latest version?

I saw a post about this new OVA version being released. I already have this deployed and everything running great... however I really need to upgrade because of this new fix: (Improved: You can disable Windows Security Center monitoring of Antivirus and Firewall, and System Updates settings). It's driving me nuts right now.

 

I attempted to upgrade my install by downloading the latest Linux installer for 6.1.28.0, Server-Linux-x86_64.sh. Upon executing it, it fails with a 1910: Error occured while preparing the database upgrade. It also breaks the server.

When I look at /var/log/eset/RemoteAdministrator/EraServerInstaller.log, it does have an indication of the problem: "Access denied; you need (at least one of) the SUPER privilege(s) for this operation"

That's the extent of my technically abilities for now, and I think I'll just wait until someone helps out here. :D

 

If anyone else has attempted this, I have figured out that by running /root/eset_installers/Server-Linux-x86_64-6.1.336.0.sh again will fix everything the way it was before.

 

Thanks for any info!

 

-Mark

 

Link to post
Share on other sites

I may be able to help. When in the console you can grant 'SUPER' privileges to the era user. Go into mysql like so: mysql -u root -p

 

When prompted for the password use the one you have set or if you haven't set any then it is just eraadmin

 

When inside mysql run this command: grant SUPER on *.* to era@'localhost' identified by 'eraadmin'; - substitute your era password.

 

Then exit; and goto your installers and run the .sh file again.

 

You shouldn't get the issue again plus the repair / upgrade will get you back to a working state.

 

Hope this helps.

Link to post
Share on other sites

I should probably mention that my GRANT is probably far too broad. You may be able to restrict it to era_db first to see if this is enough access. Eg. grant SUPER on era_db.* to era@'localhost' identified by 'eraadmin'; Remember to type in your ERA account password or if you didn't set one then eraadmin should do it.

Link to post
Share on other sites
  • Solution

I can confirm that rcraig's suggestion worked great! Thank you very much!

 

Steps taken:

 

mysql -u root -p

grant SUPER on *.* to 'era'@'localhost' identified by 'PASSWORD';      (I only have one thing using this database, so I used *.* instead of era_db. Substitute the password of course.)

 

./Server-Linux-x86_64.sh  runs with no errors now.

 

-Mark

Link to post
Share on other sites
  • ESET Moderators

Hello,

 

promised KB articles:

 

How do I upgrade ESET Remote Administrator 6.1.21 to version 6.1.28? (Windows)

 

How do I upgrade ESET Remote Administrator 6.1.21 to version 6.1.28? (Linux)

 

Please let us know if there is a scenario not described or something what does not work as described or expected.

 

Thank you.

 

P.R.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...