Jump to content

Archived

This topic is now archived and is closed to further replies.

tduffy

ERA 6, How to upgrade to newer version

Recommended Posts

When downloading the latest version 6 of ERA, when trying to run the setup on the ERA server it says it's already installed. How do you upgrade?

Share this post


Link to post
Share on other sites

Same question here. I have the old version 6 ERA installed and would like to update. I was told that by support that I'd have to do a special manual install when the new one came out, and that there would be a kb article released at the same time it came out. Not seeing it anywhere.

Share this post


Link to post
Share on other sites

Ditto. I don't really want to break my shiny, fully working ERA install :-) What's the correct upgrade procedure please (on Windows, in my case).

 

Many thanks

 

 

Jim

Share this post


Link to post
Share on other sites

Guess I should of mentioned in my original post that I'm on the Windows Platform as well. But I will also need to know how to update the proxy server I have installed

Share this post


Link to post
Share on other sites

There's a KB article, but it's only on migrating from v5 to v6. I can't find anything on migrating "v6 USA release" to "v6 Global release".

Share this post


Link to post
Share on other sites

Please see News312 for instructions to upgrade from ERA 6.1.21 to ERA 6.1.28. The upgrade instructions are located at the bottom of the News post. We are in the process of creating additional knowledgebase content to cover this procedure.

Share this post


Link to post
Share on other sites

Many thanks CB530, I've followed everything to the letter and my ERA is now updated. BUT...when I try to run "Remote Administrator Components Upgrade" I'm unable to choose a reference server. I only have one server, so I want to choose "myself" so that the clients will then update themselves. What am I doing wrong?

 

 

Jim

Share this post


Link to post
Share on other sites

Many thanks CB530, I've followed everything to the letter and my ERA is now updated. BUT...when I try to run "Remote Administrator Components Upgrade" I'm unable to choose a reference server. I only have one server, so I want to choose "myself" so that the clients will then update themselves. What am I doing wrong?

 

 

Jim

same here. that step confuses me. what devices do we run this on?

Share this post


Link to post
Share on other sites

Hi Guys,

 

Please bear with me for one moment, I don't know the exact answer to this and have reached out to our support techs for assistance. I expect that they will have an answer for you as soon as possible.

Share this post


Link to post
Share on other sites

PS I've run the agent file manually on the ERA box, which has updated the agent there. Does anythig else from the "individual downloads" file need running manually too? like MDMCore or Apache or Tomcat?

Share this post


Link to post
Share on other sites

Do these look right?

 

ESET Remote Administrator (Server), Version 6.1.365.0
ESET Remote Administrator (Webconsole), Version 6.1.282.0
Copyright © 1992-2015 ESET, spol. s r.o. All Rights Reserved.
 
Shouldn't web console have a newer version also? I did apply the tomcat folder structure, and I have rebooted.
 
 
Jim

Share this post


Link to post
Share on other sites

Any ideas on upgrading ERA Server components on a Linux server? Running CentOS 6.5 64-bit

Share this post


Link to post
Share on other sites

I am stuck at the database admin account U: and P:??

I don't remember being prompted for a Username/Password for this when I initially installed??

Share this post


Link to post
Share on other sites

I'm running Ubuntu and I just re-ran the Server and Agent installs with no arguments and it upgraded them. Also copied over the new .war for web console.

 

But...some things are acting funky. Can't start a server task probably the biggest issue.

 

Getting: Failed to load trigger types compatible with task types.

 

 

Also can't do "upgrade remote admin components" because it doesn't see my server. Although I'm guessing thats more for failover servers? I've only got the single server running.

Share this post


Link to post
Share on other sites

I too am stuck at a prompt for a username and password for a database. As well I don't recall entering one in during the regular install and just used the defaults

Share this post


Link to post
Share on other sites

I tried installing the shell scripts on the appliance version and it fails with a similar permissions issue as well.

Share this post


Link to post
Share on other sites

I am stuck at the database admin account U: and P:??

I don't remember being prompted for a Username/Password for this when I initially installed??

I used the "log in using windows authentication" option.. it worked

There is a drop down.. look for the one that has verbage as stated above..

=)

Share this post


Link to post
Share on other sites

I didn't get that extra username/password on the initial install, nor on the upgrade. However when I had a few "quirks" I tried a repair, and then I got that extra prompt. Entering a username that does, or does not, exist in the database gave me the same error; choosing to create a new user caused the entire installation to fail and rollback.

 

So some weirdness going on here I think.....

 

 

Jim

Share this post


Link to post
Share on other sites

all of my components on the RA server are not up to the new version.

Share this post


Link to post
Share on other sites

I didn't get that extra username/password on the initial install, nor on the upgrade. However when I had a few "quirks" I tried a repair, and then I got that extra prompt. Entering a username that does, or does not, exist in the database gave me the same error; choosing to create a new user caused the entire installation to fail and rollback.

 

So some weirdness going on here I think.....

 

 

Jim

 

Did it not allow you to keep the current database user, or did it clear your database at all?

 

all of my components on the RA server are not up to the new version.

 

Can you list what did/did not upgrade, did you use the same upgrade path listed in the link provided by CB530?  If so, were there any issues during the process.

 

Share this post


Link to post
Share on other sites

Hi

 

it retained the database when I ran the new MSI. Also, I was onyl prompted for the same credentials that were used for the initial install. So that's all good.

 

However if I now choose to do a REPAIR, I run through the steps but I am now prompted for a SECOND set of credentials - database admin username? - and I don't have any details for this.

 

 

Jim

Share this post


Link to post
Share on other sites

Just providing my experience from a Linux standpoint. My environment is a manually configured, dedicated CentOS 6.5 VM:

 

Yesterday I tried running the Server shell script without any parameters. The script knew to run in upgrade mode. I wound up getting hit with this error:

Error: DbPrepareUpgrade: Statement execution failed. Error: [MySQL][ODBC 5.2(w) Driver][mysqld-5.6.22]Access denied; you need (at least one of) the SUPER privilege(s) for this operation. File: /tmp/tmp.RVIn5691tQ/setup/Database/MySQL/SetupScripts/1_prepare_setup.sql

 

And then the server broke. Several times. I tried a bunch of troubleshooting methods, but then just reran the original Server installation script in repair mode and fixed everything. I'll just wait until you write up some documentation.

 

I'm glad you guys are excited about pushing out your product, but the Dev team should have sat down with some QA's once or twice and prepared some documentation with it...

Share this post


Link to post
Share on other sites

I'm glad you guys are excited about pushing out your product, but the Dev team should have sat down with some QA's once or twice and prepared some documentation with it...

 

My thoughts too. ESET are normally excellent at documenting stuff, with clear, well-written SOLN articles. But They seem a little late in coming this time around.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...