Jump to content

if you have Fedora 40 do not upgrade to version 11.0.15.0


Go to solution Solved by FranceBB,

Recommended Posts

Hi guys,

just an heads up for those who are running Fedora 40 just like me: DO NOT upgrade to version 11.0.15.0, stick to version 10.x for now as everything is broken and won't work due to compatibility issues, even real time file system protection.

image.png.47f24da9ed0bab5d1e747458226da32b.png

image.png.ac2bd64fdbd0c4b56c2cf2b7b228e841.png

 

Generally not upgrading the kernel did the trick, however I tried running version 11.0.15.0 on kernel 6.3.12, kernel 6.5.12 and kernel 6.6.34, none of which worked.

If you do upgrade, you're gonna be prompted with the error message I showed above and a simple systemctl status eea will show the following message:


● eea.service - ESET Endpoint Antivirus
     Loaded: loaded (/usr/lib/systemd/system/eea.service; enabled; preset: disabled)
    Drop-In: /usr/lib/systemd/system/service.d
             └─10-timeout-abort.conf
     Active: active (running) since Thu 2024-06-20 22:56:54 BST; 55s ago
    Process: 2085 ExecStartPre=/opt/eset/eea/lib/install_scripts/check_start.sh (code=exited, status=0/SUCCESS)
    Process: 2364 ExecStartPost=/opt/eset/eea/lib/install_scripts/launch_gui_all_users.sh (code=exited, status=0/SUCCESS)
   Main PID: 2130 (startd)
      Tasks: 57 (limit: 76412)
     Memory: 452.2M (peak: 508.3M)
        CPU: 10.708s
     CGroup: /system.slice/eea.service
             ├─2130 /opt/eset/eea/sbin/startd
             ├─2353 /opt/eset/eea/lib/logd
             ├─2354 /opt/eset/eea/lib/scand
             ├─2355 /opt/eset/eea/lib/sysinfod
             ├─2356 /opt/eset/eea/lib/updated
             ├─2359 /opt/eset/eea/lib/licensed
             ├─2360 /opt/eset/eea/lib/schedd
             ├─2361 /opt/eset/eea/lib/utild
             ├─2376 /opt/eset/eea/lib/confd
             ├─2378 /opt/eset/eea/lib/econnd
             └─2551 /opt/eset/eea/lib/oaeventd

Jun 20 22:56:53 systemd[1]: Starting eea.service - ESET Endpoint Antivirus...
Jun 20 22:56:54 systemd[1]: Started eea.service - ESET Endpoint Antivirus.
Jun 20 22:56:55 oaeventd[2551]: ESET Endpoint Antivirus Error: Cannot open file /lib/modules/6.6.34-200.fc40.x86_64/eset/eea/eset_rtp.ko: No such file or directory
Jun 20 22:56:55 oaeventd[2551]: ESET Endpoint Antivirus Warning: If you are running UEK kernel, make sure you have kernel-uek-devel installed
Jun 20 22:56:55 oaeventd[2551]: ESET Endpoint Antivirus Error: Initialization of system handler for on-access scan has failed. Please update your OS and restart your computer, then check system logs.
 

 

The error message is bogus as I have both the kernel headers and the kernel devel installed for the version of the kernel I'm currently running, Secure Boot disabled, no TPM and if anything the system is "too updated" rather than the other way round as the message is trying to (wrongly) imply.

 

Downgrading to version 10.3.4.0 works but of course that's only gonna work up to kernel 6.5.12 'cause anything newer won't be supported, which is really a shame from ESET to be fair 'cause kernel 6.6.x is an LTS kernel while kernel 6.5.x isn't and leaves people potentially exposed to unpatched vulnerabilities. It's also unfortunate that version 11 breaks compatibility with Fedora 40 completely regardless of the kernel you're running, but then again, Fedora isn't officially supported (nor is CentOS) as ESET only support RHEL 8 and RHEL 9 which cost a whopping $196.90 per year which again is a show stopper for pretty much any home user like me (hence Fedora / CentOS).

Anyway, this is after I reverted back to version 10.3.4.0 with kernel 6.5.12 on Fedora 40:

image.thumb.png.3aeb1ce8210c492b11a1525f333c90c1.png

As you can see all is well, but going forward is gonna be tricky 'cause if ESET won't release any new 10.x versions, it means that I'm gonna have to stay with kernel 6.5.x for a very long time, which, of course, it's a very bad thing security wise.

 

Edited by FranceBB
Link to comment
Share on other sites

  • ESET Staff

Hi FranceBB,

you are right, Fedora isn't officially supported, therefore we couldn't guarantee it will work as expected. I wanted to investigate what exactly is wrong with it, but it's running correctly on my machine with latest kernel. 

image.png

So most probably there is something different on your machine, if you can collect & share logs, I can check them for further investigation. 

Regards,

Kurco 

Link to comment
Share on other sites

That's very interesting and very good to know. When I get home this evening I'll try to update to the latest kernel to see whether it's gonna make any difference or not.

I'll also run the collect_logs.sh script and I'll attach them here. :) I'll keep you posted but if it works for you then I have high hopes. :D 

Link to comment
Share on other sites

  • Solution

I don't really know what to say, it worked. It doesn't make any sense, but it worked. O_O

I upgraded to kernel 6.9.5, rebooted, reinstalled eea version 11 and it just... worked:

image.thumb.png.0bec10e9c380d6ab55e63e950053b71b.png

 

Wizardry perhaps but it worked like a charm. Thank you so much for making it work with Fedora on the latest kernel, you made me incredibly happy right now. :D 

Well done indeed!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...