Jump to content

NOD32 17.1.9 cuts ping out from my PC


Go to solution Solved by Marcos,

Recommended Posts

Greetings,

recently my computer updated to current version of Nod32. Since update 17.1.9, neverthless the computer classify the subnet as "private", does not respond anymore to ping/ICMP inputs coming from other hosts in the same network, while allowing that on 17.0.16.
 

Is this the intended behaviour?
Is this a behaviour which can be changed in some way, better by subnet basis? (I wondered for half an hour into advanced settings and I found no obvious way to allow ping/icmp).

I also tried to uninstall Nod32. As a user with administrative privileges, I were able to star the uninstall, however did not succeed due to "lacking permissions" for uninstalling some service/kernel driver.

Is this also the intended behaviour? Using Eset Uninstaller currently is a no go for me (I currently don't have phisical access to the computer).

Thanks for your time.

Link to comment
Share on other sites

  • Administrators
  • Solution

Please try disabling HTTP/3 network traffic scanning as a workaround:

image.png

Link to comment
Share on other sites

Posted (edited)

Thanks for the suggestion, however nothing changed.

Computer has to be rebooted for the workaround to work?

For avoid misunderstandings: I'm trying to ping the computer with ESET Nod32 17.1.9 installed, but i receive "timeout" as answer.

Edited by Alessandro Cacciari
Link to comment
Share on other sites

I was able to ping my router's IPv4 address using ESSP ver.17.1.9 on the Public profile network connection w/o issue. I do have HTTP/3 network traffic scanning disabled.

Link to comment
Share on other sites

Posted (edited)

That's fair, i can do the same thing.

However: from your router (if capable) can you ping your computer? Or from another computer/smarphone/device/whatever.

Devices should be on the same subnet.

IMVHO, NOD32 should not "mess" with firewall setup...

Edited by Alessandro Cacciari
Link to comment
Share on other sites

19 minutes ago, Alessandro Cacciari said:

However: from your router (if capable) can you ping your computer?

No problem;

Eset_Ping.thumb.png.7948c82f1638045b45ebf6c9bb3abb5b.png

Link to comment
Share on other sites

FYI -here.

Since you are using NOD32, you are using the Win firewall. On Win 10/11, ping firewall rules are not enabled  by default. Also, no default ping firewall rules exist for the Public profile. Check your Win firewall rules.

WF_Ping.png.34016a4e1d20aee2c5d121d4146a4804.png

Link to comment
Share on other sites

Thanks for sharing, might help other people having the same issue.

On this computer, before (Nod32 17.0.16) ping was working nice and as intended. Then I updated to 17.1.9, then reboot, and the ping stopped working. None Windows Firewall parameter has changed while upgrading.

 

 

Link to comment
Share on other sites

  • Administrators

Does temporarily uninstalling ESET NOD32 Antivirus actually make a difference and the issue returns as soon as you install v17.1.9 from scratch with default settings?

Link to comment
Share on other sites

Posted (edited)

For helping reproduce the issue.

  • Windows 10 fresh installed
  • mark connected network as "private"
  • allow file sharing (40bit encryption on file sharing allowed)
  • share a folder
  • mark "allowed" in windows firewall file and printer sharing services
  • ping should be responded from the same subnet
  • folder should be accessed from other computers
  • Install ESET Nod32 17.1.9
  • Reboot
  • ping is not responded from the same subnet
Edited by Alessandro Cacciari
Link to comment
Share on other sites

  • Administrators
7 minutes ago, Alessandro Cacciari said:

Update, just tested with Windows 11. Change the OS into upper post, then apply this

And... worked.

Strange because I asked if disabling HTTP/3 traffic scanning made a difference and you wrote:
"Thanks for the suggestion, however nothing changed."

Link to comment
Share on other sites

I enabled HTTP/3 scanning on my ESSP Win 10 x(64) Pro 22H2 installation and can ping w/o issue.

Then there is the question of what does HTTP/3 scanning have to do with ICMP processing?

Link to comment
Share on other sites

3 minutes ago, itman said:

Then there is the question of what does HTTP/3 scanning have to do with ICMP processing?

FWIW I have the same question too 🙂

However currently I'm more interested realizing (and apply) a working solution for the  issue. At least for Windows 11 my test confirm that workaround works as suggested.

Link to comment
Share on other sites

I had the same problem pinging servers from CLI using IPV6 address. No problem at all with IPV4.

A lot of timeouts.

Desactivating "Enable HTTP/3 traffic scanning" solved the issue.

Thank you.

Link to comment
Share on other sites

  • Administrators

Please kindly proceed as follows:
1, Enable advanced network traffic scanner logging (advanced setup -> Tools -> Diagnostics)
2, Start capturing the network communication with Wireshark
3, Reproduce the issue
4, Stop logging and save the Wireshark log.
5, Collect logs with ESET Log Collector
6, Supply us with both ELC and Wireshark logs for perusal.

Link to comment
Share on other sites

  • 2 weeks later...

Sorry for the delay....

@Marcos I did not followed the detailed instructions you provided.

"Working without antivirus" on that Windows 10 client was better than "not working with antivirus", at least for the short period.

Solution you provided worked for a other computers (Windows 11 and Windows 10), on the problematic client I decided to reset Windows Firewall configuration, then allow every service was needed. That had to be done "offtime", due to the necessity of working computer as expected.

Recently I updated both Windows 11 and Windows 10 computers with Nod32 17.1.11 and the "workaround" you suggested for 17.1.9 was indeed not needed.

Thansk for the support, if not needed this thread for my opinion can be closed.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...