Jump to content

ERA Web console does not reflect changes


Go to solution Solved by Marcos,

Recommended Posts

Hello MASTERS,

My problem is that the era web console does not update the status of the pcs. In other words: The console indicates that computer XX must be restarted to apply the update. I have restarted it manually (making sure it updates correctly and that there are no errors in the status.html file on PC XX --> C:\ProgramData\ESET\RemoteAdministrator\Agent\EraAgentApplicationData\Logs) but the console does not reflect the changes... 

It's been several hours since I manually updated all the computers but the console still doesn't notice.

These some details about my era web console:

 

Quote

ESET PROTECT on-prem (Server), Versión 11.0 (11.0.199.0)

ESET PROTECT on-prem (Consola web), Versión 11.0 (11.0.193.0)

Copyright (c) 1992-2023 ESET, spol. s r.o. All Rights Reserved.

CentOS (64-bit), Versión 7.9.2009

Clientes conectados: 39

Activar licencias: 1

Componentes instalados:

NOMBRE
VERSIÓN
Módulo de actualización
1085 (20231103)
Módulo de soporte de traducción
1999 (20240214)
Módulo de SysInspector
1283 (20220614)
Módulo de SSL
1082 (20231106)
Módulo del servicio de notificaciones
1137 (20240208)
Módulo de configuración
2109.2 (20240213)

Información de la base de datos:

Nombre de BD: era_db

Versión de BD: MySQL 8.0.33

Tamaño de BD: 130 MB

Nombre de host de BD: ESET-PROTECT

Usuario de BD: era@localhost

 

Link to comment
Share on other sites

  • Administrators

Is it reported locally in Endpoint's gui that the computer must be restarted for the update to take effect? If not, couldn't it be that this application status is set not to be reported locally in gui? Does rebooting the client manually via "shutdown /r" make a difference?

Link to comment
Share on other sites

Hi @Marcos Thank you for your kindly response!!

locally in Endpoint's gui is not reported that the computer must be restarted to apply the update. I have seen that need for a reset in the era web console. What I did right after seeing it was go to the computer, open ESET and run the update manually. And then restart the computer. After all, when I look back at the console it still says a reboot is required. And it also says that the last connection time of that computer was two months ago... I dont understand anything...

Link to comment
Share on other sites

  • Administrators

Is there an error reported in C:\ProgramData\ESET\RemoteAdministrator\Agent\EraAgentApplicationData\Logs\status.html  and trace.log on that machine then?

Link to comment
Share on other sites

Indeed, you are absolutely right!!

There is an error logged in status.html file about something wrong with DNS resolution. Here is:

Quote

Error: Replication connection problem: DNS resolution failed (code: 14) for request Era.Common.Services.Replication.CheckReplicationConsistencyRequest (id: 434b1cb1-2868-4ec5-8c44-5dd3475a9707) on connection to 'host: "SRVESET" port: 2222'

  • Task: CReplicationConsistencyTask
  • Scenario: Automatic replication (REGULAR)
  • Connection: SRVESET:2222
  • Connection established: false
  • Replication inconsistency detected: false
  • Server busy state detected: false
  • Realm change detected: false
  • Realm uuid: acf49f3c-83f9-468d-9653-52b8a32383e6
  • Sent logs: 0
  • Cached static objects: 0
  • Cached static object groups: 0
  • Static objects to save: 0
  • Static objects to delete: 0
  • Modified static objects: 0
  • All replication attempts: 10

 

Link to comment
Share on other sites

Ok, I answer myself... The problem is the hostname. The computer is trying to connect to "SRVESET" but the correct hostname is "ESET-PROTECT".
Now my question is: How can I change that in the computer that fails?

Link to comment
Share on other sites

  • Administrators
  • Solution

Re-redeploy the management agent while specifying a correct server name during installation.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...