Jump to content

Impossible to install or uninstall NOD32 8.0 / 7.0 (Windows Installer error - DLL)


Recommended Posts

I am having a lot of problems to install or uninstall ESET NOD32 7.0 or 8.0 version.

I always get the same error, a Windows Installer error, asking me for a DLL and NOD is not offering me any kind of information about what kind of DLL is this? where to find it? or how to solve the problem?

The result is, I cannot install the antivirus or even I cannot uninstall it.


Please, see the screenshot here, this is the error I get:



You'll see it in Spanish, because I am in Spain, but what it says is:

There is a problem with this Windows Installer package. A DLL required for this install to complete could not be run. Contact your support personnel or package vendor.


When I tried to uninstall NOD32 7.0 I got that error.

I had to suffer a lot to remove the NOD32 7.0 having to restart the computer in safe mode and using the ESET Removal tool... (ESET Uninstaller)...

finally I got rid out all these problems and... then I had my system clean without NOD32 7.0


Then I decided to install NOD32 8.0...

Again the same problem !!!


There is a problem with this Windows Installer package. A DLL required for this install to complete could not be run. Contact your support personnel or package vendor.



This is very frustraing, seems to be I have problems uninstalling or reinstalling... and I suspect this happen because ESET provide the installers in MSI and don't give EXEs like many people do...


Do we have a solution for this?

I am using NOD32 since the version 3.0... but sadly, since the version 7.0 we are having so much problems that I am considering to use a free utility such as Panda Cloud or Windows Defender and not suffering these problems anymore... unless there is an easy solution to install and uninstall the software without having to lose hours and hours...


Any idea about how to solve this?



Edited by mrmister
Link to comment
Share on other sites

  • Administrators

I'd like to bring into your attention this article:



... after going to Properties > Security on the C:\Users\x\AppData\Local\Temp folder and giving that Everyone the Full control permission, installers that previous had been failing now worked! Hooray! Since Everyone already had Read and Write access, I suspect that Full control also added a necessary Execute permission.


Maybe booting to safe mode, deleting the above mentioned folder and creating it from scratch would be a nicer solution as you'd avoid changing permissions which may not be secure if set up incorrectly.

Link to comment
Share on other sites

Hello I did not understand very well what you want me to do with this folder...

I guess you mean exactly the temp folder?



Well, the temp folder is not empty and other programs have information inside, if I delete it, for sure I'll botch something...

I've been taking a look to the permisions in that folder, and it has write and read permissions...

I am administrator in my system...


So I really don't know what's going on here?


Finally, after reading that article you told me, THANKS GOD, I was able to start the installer (after a whole day suffering)... seems to be the problem are msi files cannot be given administrator rights, and then, in some computers they cannot be installed or uninstalled by doing double click, they need administrator rights.

I'm wondering why ESET don't use EXEs like many people do?


Anyway... I think is necessary to find a solution to make the installer start, without having to type special commands... because not all people have that patience, and having a lot of free antiviruses online or even the windows defender, I guess many frustrated users would uninstall the NOD32 and go to other free solution.

I think it's necessary we find a solution for this, not having to type any special command.


What I did to make the installer start was the following...

1. Move the mouse to the right corner in Windows 8.1, I see the menu, then I click on Search

2. I type CMD and then I see the icon of the system symbol...

3. With my mouse I did right click over it, and then, run as administrator

4. Now, with the black window of the system symbol, I entered in the antivirus folder where I have the msi file...

5. There, I typed msiexec /i eav_nt64_esl.msi

6. After doing this, the installer started normally...


Well, it's clear this is something about permissions... and it is clear this is happening in some computers and other computers don't have this problem... because I took the same msi file to other computer, just for testing purposes, and I was able to start the installer just doing double click...


So, please, tell me how can we fix the permissions thing over this particular file, the msi file to fix this?



Edited by mrmister
Link to comment
Share on other sites

  • Administrators

Maybe a problem with UAC on your system? Were you prompted by UAC to allow changes before the setup wizard started copying files?

Link to comment
Share on other sites

Yes, I am prompted and even I tried the set the UAC off so any program would be able to make changes without having to ask for permissions. No effect. The msi file don't run, because it has no administrator rights. Today I have installed sucessfully NOD32 8.0 using the command line, and doing what I said, executing CMD with administrator rights and typing msiexec /i eav_nt64_esl.msi

I have 5 computers at home. I tried with 3.

In 2 computers I have this problem with the msi file, the DLL problem because the msi file don't run with administrator rights.

In the 3rd computer, I don't have this problem, and I am able to install the msi file just doing double click.

Hence, we have a problem that happen in certain computers and affect the ESET NOD32 installations.

If I have this problem in 2 computers from 3, then it's clear more people wordlwide is having this problem and they simply cannot install NOD32...

So the problem I think is affecting right now ESET, because not all people have the skills to type those commands, many people just browse the ESET website and want to download the installer and install it in a few clicks. When those users get the error, they are discouraged and try other antivirus...

I think it's urgent ESET solve this.

What I have in mind right now is how can we make a snapshot from my system? so ESET technicians can find for what reason is happening this here, what cause the problem and solve it?


A question, what function do the file callmsi.exe ? does it has any relationship with the install / uninstall process?

perhaps giving this file administrator rights we could solve the uninstall process without having to restart in safe mode and using the ESETUninstaller...

(that is the test I will do tonight)

Edited by mrmister
Link to comment
Share on other sites

Well, after doing tests for 4 hours, trying to uninstall NOD32 8.0 or 7.0 is impossible it gives, the DLL error and the only way to remove it is using the ESETUninstall utility.

Regarding the installation, it's impossible by doing double click on the MSI file, the only way is the one I described before, with administrator rights on the command line and typing msiexec /i eav_nt64_esl.msi

This happen in 2 computers, I tested this in 3. The third one, can install the MSI file perfectly.

Seems to be there is a miss configuration or particular scenario in which the MSI file fails, and this scenerio happen under normal Windows configurations, because the problem is happening in two of my computers.

This is the farthest I can reach to try to solve the issue.

Due this problem is a global problem, I think it's important someone from ESET contact me to recover information from my computer and help ESET to identify the problem.

At this point I want to clarify I have the antivirus installed and working, so it's not a help for me.

What I mean is this problem is affecting to more people... and I think ESET should recover information from my system to understand why this is happening...

Actually with the 360 Total Security running out there and offering for free a lot of virus search engines from many antiviruses like Avira o Bitdefender, I think the actual situation (just an opinion) shouldn't complicate the installation / uninstall process to the curious user that want to install the software... so I think ESET should solve this problem soon. Just my two cents about this.

Edited by mrmister
Link to comment
Share on other sites

  • Administrators

In fact, you are the only user who has ever reported this issue and everyone else was able to install ESET products fine. Instead of using an msi installer, I'd recommend running Live Installer which is downloaded by default and can fix many issues with system misconfiguration that would otherwise cause the installer to fail.


As for disabling UAC, I don't think simply disabling it would solve permission issues, quite the contrary. Once upon a time I ran into this issue (not sure if it was with ESET or another product) and since I didn't want to be bothered by UAC prompts and disabling UAC caused other permission issues, I had to resort to reinstalling the OS as there must have been something terribly wrong with UAC. I've found this issue to be reported with other software as well, for instance hxxp://superuser.com/questions/545569/disabling-uac-on-windows-8-causing-issues-with-installations.


You could try re-enabling UAC to see if it makes a difference. Once the msi installer is run with elevated administrator rights, it shouldn't cause any permission issues. If UAC doesn't work correctly as expected (being enabled or disabled), issues are expected to occur.

Link to comment
Share on other sites


Sorry I don't understand very well your recommendation. You recommend me to run Live installer to run msi files with administrator rights? Please, could you tell me how may I do that? should I install something or download something?

Regarding what is happening in my system, it's clear something happen in certain configurations that stop to install the msi files, so I think I should provide my system information to the ESET engineers, so they can make the install process more easily to the users. I'm willing to help, but no one from ESET contacted me before.

Please, let me know about that thing of the Live Installer? what should I do ?



UAC is activated right now. I had it always activated except when I was trying to install the msi files, I disabled the UAC a few minutes just for testing purposes, but yes, right now is completely activated. UAC is very necessary to maintain the PC safe.

Link to comment
Share on other sites

Oh you meant the NOD32 8.0 Live Installer which is an EXE file? oh okay. The installation process is the same as the MSI file or change something?

I know the live installer download the antivirus from Internet and the MSI don't require Internet connection, what I don't understand very well is why ESET is offering the offline installer in MSI and the Live Installer in EXE?

For what reason they don't offer both installers in an EXE file?

Just wondering... why

Edited by mrmister
Link to comment
Share on other sites

I'm wondering why ESET don't use EXEs like many people do?

The majority of the installers use Windows Installer. In many cases these one have the file extension MSI.

However also many of installers with the file extension EXE use Windows installer. EXE-installers mostly just use a (more) customised interface, but work with Windows Installer in the background.


What I have in mind right now is how can we make a snapshot from my system?

Generally this can be done with ESET SysInspector, which is included in the ESET products and available online as a free download.


Now about the Live Installer:

The Live Installer for NOD32 is available here. However AFAIK it is also using Windows Installer (like I described above), but it has to be started with elevated rights right at the start, so this may also solve the problem, because it does nearly the same as your workaround with starting Windows Installer as an admin.


However your issue seems to be related to Windows Installer (more than it is related to ESET), so have you tried any other MSI file which requires elevated privileges (which should be nearly every installer, because nearly every software installs in %programfiles%)?


But back to the ESET installation: Maybe there are some logs of the installation process. AFAIK they will be automatically created in %temp% (they should have the format "Msi*.log"). If not then you can also follow this instructions to enable logging and then reproduce the issue.

Maybe you can also try installing (the latest version of) Windows installer (although it should automatically up to date with Windows update) or reinstalling Windows installer.

Edited by rugk
Link to comment
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...