Jump to content

Agent certificate unknown password


Recommended Posts

Hi!

I'm in the process of migrating Eset Protect on-premises from Windows/MSSQL Server to Debian/MySQL and for that I'm following KB7907 and KB7710. I have successfully installed and configured Eset Protect on Debian and now I'm about to migrate endpoints to it. But I'm having issues with Agent certificate password at the step V. Migrate client computers from the old server, figure 4-7 on KB7710. The certificate exported from Debian instance is password protected and I can't figure which password is used. So far I tried to:

  1. Importing certificate using Windows Certificate Import Wizard (WCIW) and testing password used during installation (--server-root-password);
  2. Revoke current certificate and generate new one without password and test with WCIW;
  3. Revoke current certificate and generate new one with a password and test with WCIW;

Some considerations:

  • All the steps above was also tested on Eset Protect on old server following figure 4-7 on KB7710;
  • No other password was set during Debian installation besides --db-admin-password, --db-user-password and --server-root-password.

I'm stuck on that process and I'm looking any advice on what to do. The only thing I can see as a solution to test so far is to reinstall Eset Protect and setting  --peer-cert-password.

Link to comment
Share on other sites

I decided to reinstall from scratch, now setting some parameters regarding passwords. The following command and settings were used:

$ ./server-linux-x86_64.sh \
--skip-license \
--db-type="MySQL Server" \
--db-driver="MySQL ODBC 8.3 Unicode Driver" \
--db-hostname=localhost \
--db-port=3306 \
--db-admin-username=root \
--db-admin-password="root" \
--server-root-password=password \
--server-cert-password=password \
--peer-cert-password=password \
--cert-auth-password=password \
--agent-cert-password=password \
--db-user-username=erauser \
--db-user-password=erauser \
--cert-hostname="192.168.0.5"

Setting the password above still renders to wrong password while trying to set the agent certificate.

 

Capture.PNG

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...