Jump to content

Profile problems - Can't use Profiles as I used to


Recommended Posts

I upgraded from 16.1.14.0 to 17.0.16 and I'm having problems using the profiles that were working before.  For me my profiles are named "GTA V", "Visual Studio Update",  "WIndows Update", and similar - they represent certain tasks I want to perform.  For example, update Visual Studio, or play GTA V.  They don't take effect based on network traffic types - indeed I want ALL traffic subjected to the active profile after I select it.

But it looks like you can't select a profile any more.  In 17.x, profiles seem to be automatic rules that are activated based on the type of packets, origin network, etc.  This is not at all how I was using profiles and makes them useless to me.  I really wish the 16.1.x behavior would be brought back, at least as an optional mode.

So this brings me to the first question.  Profiles now seem to have "activators" that switch them on.  My profiles like "GTA V" have no activators so they are not used at all.  Is there an "always true" activator that I can manually add to a profile to make it always apply?  For example, "Network: any," something like that?  Is there a place where the legal syntax for "activators" is described?

Secondly, there's a very obvious bug in 17.0.16 with the product that scares me because it would seem to say that you're not even doing basic testing on your released products.  If I go to the firewall rules, I can click on a rule and on the right a little details pane will show the profile for the rule (created in 16.1.x).  But, if I edit the displayed column set to add "Profile" to the displayed columns, profile is wrongly shown as Any for every record, even records that show the correct, non-Any profile in the right details pane.

Is this already filed as a bug, and if not, how would I file it as a bug?

Link to comment
Share on other sites

Marcos, I see that you've replied to posts made after mine.  Why haven't you responded to the questions in this thead?  This issue is blocking me from installing the new release.

Link to comment
Share on other sites

  • Administrators
1 hour ago, MrZork said:

Marcos, I see that you've replied to posts made after mine.  Why haven't you responded to the questions in this thead?  This issue is blocking me from installing the new release.

Please always create a support ticket for things when a replication in needed. It is very difficult for us moderators to replicate issues during holidays in our free time which requires quite a lot of time. It's different to answering relatively simple questions which takes a few minutes at most. Anyways, I'll try to reproduce the issue with firewall rules migration from v16.1 to v17 in the following days but I don't expect it to be a general issue, otherwise users who have upgraded to v17 would have reported it as well. Therefore I kindly ask you to raise a support ticket for proper investigation of the issue.

Link to comment
Share on other sites

  • Administrators

I've tried it and created a rule for profile "1" in v16.1. After upgrade to v17, the rule was retained and correctly assigned to this profile:

image.png

image.png

Link to comment
Share on other sites

You tested and showed something I explicitly said worked:

Quote

If I go to the firewall rules, I can click on a rule and on the right a little details pane will show the profile for the rule (created in 16.1.x)..

What I explained didn't work, was adding a column to the grid for "profile":

Quote

But, if I edit the displayed column set to add "Profile" to the displayed columns, profile is wrongly shown as Any for every record, even records that show the correct, non-Any profile in the right details pane.

And you ignored the initial question about why profiles were changed to have a completely different meaning, and my general question about how to write an "always true" activator for a profile and where the syntax for activators is documented.  These don't require "replication."

 

Edited by MrZork
Link to comment
Share on other sites

  • Administrators

I didn't notice the option to display the "Profile" column before but now I was able to reproduce it and the issue is now tracked.

As to whether there are plans to bring firewall profile selection in the advanced setup, I can't tell without asking developers which will be possible in about 1 week time at earliest. I'd recommend raising a support ticket so that it's tracked in the system.

P_ESSW-17665

Link to comment
Share on other sites

What about my question about manually enabling a specific profile with an "always true" activator?  Where are the docs on "activators"?  How would I create an "always true" activator?

Edited by MrZork
Link to comment
Share on other sites

OK, this is getting very frustrating.  Everyone is back from vacation and on normal hours, right?  Can I please get an answer to my question?  As I said, I'm stuck and not able to activate profiles with 17.x.

On 12/31/2023 at 5:45 AM, MrZork said:

What about my question about manually enabling a specific profile with an "always true" activator?  Where are the docs on "activators"?  How would I create an "always true" activator?

 

Link to comment
Share on other sites

  • Administrators

I've asked the firewall developer and here is the answer:

1. It is possible to create a profile that will always match. To do that, create a profile and add an empty activator (just click OK in the "Add activator" window).

2. Alternatively you can manually choose a profile for a specific network connection (this will override automatic profile selection for the given connection). In the main gui go to Setup>Network>Network connections. This is, however, only for that particular connection, for a global profile you need to use option 1.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...