Jump to content

Windows Security Center Service unable to load instances of AntiVirusProduct from datastore.


Zardoc

Recommended Posts

Marcos, Just a question,

Why don't I see this problem with version 16 of the AV on the same windows 11 build and get issues with version 17?

Installed and uninstalled version 17 twice with same issue. Security center is always grayed no matter what version of AV.

It's set to delayed start for version 16. I never get the error message.

image.thumb.png.0542f12bb3f817cb04ea30b6fe456c21.png

Edited by Zardoc
Link to comment
Share on other sites

For those having issues with Win 11 Security Center with ver. 17 installed, it is critical you post back your finding to what @Marcos requested here: https://forum.eset.com/topic/38760-windows-security-center-service-unable-to-load-instances-of-antivirusproduct-from-datastore/?do=findComment&comment=175846 .

When the Security Center displays Eset data as shown in the above linked screen shot, it indicates Eset has been successfully registered in Security Center as the active real-time AV solution.

Link to comment
Share on other sites

When the Security Center displays Eset data as shown in the above linked screen shot, it indicates Eset has been successfully registered in Security Center as the active real-time AV solution."...........it is indeed on my Win11, then why(??) these eventlog-errors ( id=18 and id=19 ) still ???

ESET version16 does not make any eventlog-error at all , so it seems this 17-version is corrupt .........

btw ; when trying to update the program ( from 16 to 17 ) , this version ( 17 ) is not offered anymore....

Edited by Pete12
Link to comment
Share on other sites

  • Administrators

We are waiting for further ELC logs from such machine. The Security Center has always been required to run in order for any 3rd party AV to register in the system. Without that Windows would not disable Windows Defender either.

Link to comment
Share on other sites

1 minute ago, Pete12 said:

it is indeed on my Win11, then why(??) these eventlog-errors ( id=18 and id=19 ) still ???

The main point is that Eset ver. 17 is properly installed in Win 11 which it appear it is.

As far as the Event log error, I suspect it is related to the Microsoft Azure code signing cert. Eset is using to sign all its software now. It appears "not to play nicely" with Win 11 Security Center validations. On that regard, nothing new since Eset never has properly signed its eamsi.dll;

Eset_CI.png.2b9e0f9b397fed3e213f2a6ce16cdac9.png

Link to comment
Share on other sites

 It appears "not to play nicely" with Win 11 Security Center validations. On that regard, nothing new since Eset never has properly signed its eamsi.dll; "..............dont you think its time to change this behaviour ?

Impossible to update , without eventlog-errors , if ESET wont properly signed its eamsi.dll........

Link to comment
Share on other sites

  • Administrators
12 minutes ago, itman said:

As far as the Event log error, I suspect it is related to the Microsoft Azure code signing cert. Eset is using to sign all its software now. It appears "not to play nicely" with Win 11 Security Center validations. On that regard, nothing new since Eset never has properly signed its eamsi.dll;

Eamsi.dll is properly signed. This would be reported for any 3rd party AV except Defender since Microsoft can sign their files with a certificate that allows loading their dlls into protected system processes.

Link to comment
Share on other sites

Security Center service not running ".............how (??) do I know if its running or not ?

I still cant find this service in my service-folder ( there are a lot of them ) !

Link to comment
Share on other sites

  • Administrators
Just now, Pete12 said:

Security Center service not running ".............how (??) do I know if its running or not ?

I still cant find this service in my service-folder ( there are a lot of them ) !

Please provide logs collected with ESET Log Collector for perusal.

Link to comment
Share on other sites

  • Administrators

Currently you can update to v17 either by using the offline installer from the website or by switching to the pre-release update channel. We expect program update from the regular update channel to be resumed this week.

Link to comment
Share on other sites

  • Administrators
1 minute ago, Pete12 said:

Guess better wait for the new release............🙂

What new release do you mean? We don't plan to release any newer version, we'll resume automatic upgrade to v17.0.15.

Link to comment
Share on other sites

What new release do you mean? We don't plan to release any newer version, we'll resume automatic upgrade to v17.0.15. ".................I dont understand , how(?) can we upgrade from 16 to 17 , with these eventlog-errors ( Im not the only one with id=18 and id=19 , see all the previous posts !) .

Then we have to wait for a fix ...........

If not , have to stay at 16-version !

Link to comment
Share on other sites

  • Administrators

Still waiting for ELC logs from other machines with this issue. So far we've got ELC logs only from one machine where the Security Center service was not running. We need more ELC logs to determine a common pattern.

Link to comment
Share on other sites

1 hour ago, Zardoc said:

Can you reply to my post 23 plz?

I assume you are referring to this;

On 11/19/2023 at 8:45 AM, Zardoc said:

It's set to delayed start for version 16. I never get the error message.

image.thumb.png.0542f12bb3f817cb04ea30b6fe456c21.png

Please clarify your question. This current Security Center Event log error entry only exists for Eset ver. 17.

Edited by itman
Link to comment
Share on other sites

My question is why doesn't this error happen with version 16 in Windows 11 that I'm using?

If I install 17 the errors start. I remove and use version 16, errors stop.

Link to comment
Share on other sites

  • Administrators
2 minutes ago, Zardoc said:

My question is why doesn't this error happen with version 16 in Windows 11 that I'm using?

If I install 17 the errors start. I remove and use version 16, errors stop.

Is the Security Center service running when v16 is installed? When v17 is installed it's not running as the logs showed?

Link to comment
Share on other sites

Yes it isMy question is why doesn't this error happen with version 16 in Windows 11 that I'm using?

If I install 17 the errors start. I remove and use version 16, errors stop.

Link to comment
Share on other sites

"  If I install 17 the errors start. I remove and use version 16, errors stop. " ...............yes, same problem with 17 on my Win11 latest.............!!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...